locked
Starting RAS server RRS feed

  • Question

  • Hi,

    I have to establish a PPP connection via RS232 cable between my WinCE6.0 equipment and another type of device.

    The Win CE 6.0 should be the server and the other device should be the client.

    i.e. External device should send to WinCE equipment the following message "CLIENT"... several times

          The WinCE should reply with "CLIENTSERVER".

    Usually, I establish the PPP connection in Windows XP platform with configuring the COM on modem list and starting the "routing and remote access" service.

    I don’t know if there is a programmatically method (C++) to establish this kind of connection.

     

    Friday, May 16, 2014 8:57 AM

Answers

  • That basically means that your device does *not* have the RAS Server built-in.

    To include the RAS Server feature in the OS running on that device, make sure to include the Catalog Item named "RAS Server/PPTP Server (Incomming)" in your OS design.

    If you're using a off the shelf device, contact the vendor of your device. He should be able to provide you with an OS that includes the required components.


    MVP Windows Embedded

    • Marked as answer by MRAB Wednesday, May 28, 2014 10:02 AM
    Thursday, May 22, 2014 10:41 AM

All replies

  • There are APIs to configure the RAS Server on a Windows Embedded CE 6.0 based device.

    Please find the documentation and sample how to do this in MSDN unter "RAS Server/PPTP Server (Incoming) (Windows Embedded CE 6.0)" ( http://msdn.microsoft.com/en-us/library/ee498674(v=winembedded.60).aspx)


    MVP Windows Embedded

    Saturday, May 17, 2014 1:15 PM
  • Thank you for this replay. It is very helpful, but I have a problem when configuring the registry settings.

    I could not find the global server settings keys: "HKEY_LOCAL_MACHINE\Comm\ppp" is not available.http://msdn.microsoft.com/en-us/library/ee500576%28v=winembedded.60%29.aspx.

    Is that means that the RAS server is not available on my WinCE 6.0 device?
    How can I resolve this problem?

    Thanks

    • Edited by MRAB Tuesday, May 20, 2014 2:11 PM
    Tuesday, May 20, 2014 1:10 PM
  • No, not necessarily - the RAS Server has built-in defaults for all registry parameters.

    There is an easy way of detecting whether your device has the RAS server functionality.
    In the '\Windows' directory on the device resides a file name 'ceconfig.h'. That file lists all the features/components available in this OS image.

    If your device has the RAS server, you should find the following two lines in this file:

    #define CE_MODULES_PPP 1
    #define PPP_PPP2SRV 1
    If you want to specify different settings, just create the required registry key and the appropriate values yourself.


    MVP Windows Embedded

    Wednesday, May 21, 2014 3:48 PM
  • Than you Michael for your answers. It is verfy felpful. But it still always unable to start the PPP connection.

    I have followed the instraction described in the http://msdn.microsoft.com/en-us/library/ee498674(v=winembedded.60).aspx guide.

    I have found theCE_MODULES_PPP define in the ceconfig.h but I have not found the PPP_PPP2SRV.

    I have found a similar definition

    #define PPP_PPP2SRVSTUB 1

    Thursday, May 22, 2014 8:29 AM
  • That basically means that your device does *not* have the RAS Server built-in.

    To include the RAS Server feature in the OS running on that device, make sure to include the Catalog Item named "RAS Server/PPTP Server (Incomming)" in your OS design.

    If you're using a off the shelf device, contact the vendor of your device. He should be able to provide you with an OS that includes the required components.


    MVP Windows Embedded

    • Marked as answer by MRAB Wednesday, May 28, 2014 10:02 AM
    Thursday, May 22, 2014 10:41 AM
  • Ok I will contact the vendor of device in order to give me another OS version and I hope that will solve my problem.
    Tanks Michael.
    Thursday, May 22, 2014 11:28 AM
  • Thank you Michael the connection is established correctly now.
    Thank you very much for your support.
    Wednesday, May 28, 2014 10:02 AM