none
Help with P2S RADIUS VPN - Can't Connect RRS feed

  • Question

  • Hello. Please can you help me in trying to get my P2S RADIUS VPN set up? Following this guide, https://docs.microsoft.com/en-us/azure/vpn-gateway/point-to-site-how-to-radius-ps my environment looks like:

    VNET: 10.10.0.0 /16
    Server Subnet: 10.10.0.0 /24 - NPS Servers is also the DC 10.10.0.4
    GatewaySubnet 10.10.1.224 /27
    Client Address Pool: 10.11.0.0 /24
    I am using SSTP.

    For the RADIUS server I am using Server 2016. I installed the NPS role and followed the Wizard. I have set up the RADIUS client as the public IP from the VPN. MSCHAPv2 is the authentication.

    From a Windows 10 Azure VM (not on the same VNET) I run the downloaded client and get this error:

    The connection was prevented because of a policy configured on your RAS/VPN server. Specifically, the authentication method used by the server to verify your username and password may not match the authentication method configured in your connection profile. Please contact the Administrator of the RAS server and notify them of this error. (Error 812)

    and in the log:

    [cmdial32] 15:23:38 21 On-Error Event ErrorCode = 812 ErrorSource = RAS


    On the NPS Server I get this error in the event log EventID 13

    A RADIUS message was received from the invalid RADIUS client IP address 10.10.1.228.

    But my client is MSCHAPv2 / SSTP and so is the VPN.

    Please can someone help?

    Thanks!


    • Edited by H A M J A M Monday, December 4, 2017 4:18 PM
    Monday, December 4, 2017 4:17 PM

Answers

  • I have seen this issue being reported by other customers primarily on Windows 10. Could you, therefore, take a look at this thread that provides a possible solution to this issue?

    Also, have you tried the same on a non-Windows 10 machine? If it does work on other machines then it likely needs the attention of Windows 10 OS experts to explain why this is the case.

    -----------------------------------------------------------------------------------------------------

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    • Marked as answer by H A M J A M Tuesday, December 5, 2017 12:28 PM
    Tuesday, December 5, 2017 5:32 AM