locked
keep getting jquery error sign after uploading ajax control toolkit ?? RRS feed

  • Question

  • User-631683198 posted

    hi,

    I just downloaded the latest Ajax control toolkit and uploaded the  Toolkit.Dll file

    to the server.

    On one of my pages I keep getting the below on entering a page

    "a script on this page may be busy or it may have stopped responding

    open the script in debugger"

    script  https//ajqax.googleapis.com/aj..bs/jquery/1.11.2/jquery.min.js2

    In the head section I have the following code


    <asp:Content ID="Content1" ContentPlaceHolderID="head" Runat="Server">




        <meta name="viewport" content = "width = device-width, initial-scale = 1.0, minimum-scale = 1.0, maximum-scale = 1.0, user-scalable = no" />


        <link href="../FooTable-2/css/footable.core.css" rel="stylesheet" type="text/css" />
     <link href="../FooTable-2/css/footable.standalone.css" rel="stylesheet" type="text/css" />
        <script src="../FooTable-2/js/footable.js" type="text/javascript"></script>




        <meta name="SKYPE_TOOLBAR" content="SKYPE_TOOLBAR_PARSER_COMPATIBLE" />
     
     <link href="Static1.css" rel="stylesheet" />
        

        <link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css">

       
          <style type="text/css">
              
              
                    table {
              
              margin-top:50px;
              margin-bottom:50px;
            }
     
              
            table,td {
              
              
                padding:10px;
                padding-bottom:20px;
                 padding-top:20px;
                text-align:left;
                 border-width:0px;
                border-style:none;
                border-bottom:dotted;
                border-bottom-width:1px;
            }
     

        </style>

          



    </asp:Content>

    In the master page I have the following


    <!DOCTYPE html>

    <html xmlns="http://www.w3.org/1999/xhtml">
    <head runat="server">
        <meta name="viewport" content="width=device-width, initial-scale=1">

    <title></title>
        <META NAME="ROBOTS" CONTENT="NOINDEX, NOFOLLOW">


    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.4/css/bootstrap.min.css">
    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.4/css/bootstrap-theme.min.css">
    <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js"></script>
    <script src="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.4/js/bootstrap.min.js"></script>
     
        <link href="../Static1.css" rel="stylesheet" type="text/css" />

        <link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css">


        <script src="../Respond-master/dest/respond.src.js"></script>





        <meta name="SKYPE_TOOLBAR" content="SKYPE_TOOLBAR_PARSER_COMPATIBLE" />
     

    </head>



       
        
       <asp:GridView ID="GridView1" CssClass="footable" runat="server" onrowcommand="GridView1_RowCommand" onrowdatabound="GridView1_RowDataBound" AutoGenerateColumns="false"
        Width="100%" GridLines="None" DataKeyNames="EmailId">
            <Columns>




            
        <asp:BoundField DataField="EmailId" HeaderText="EmailId"
                    InsertVisible="False" ReadOnly="True" SortExpression="EmailId"
                    Visible="False" />





                            
                    <asp:TemplateField HeaderText="Remove" ItemStyle-HorizontalAlign="Center" HeaderStyle-HorizontalAlign="Center"> <ItemTemplate>
                    
                 
                      
                                        <asp:LinkButton ID="LinkButton1"  runat="server"  CommandName="cmdBind" CommandArgument='<%#Bind("EmailId") %>'>Delete</asp:LinkButton>
                    
                      
                    
                    
                    </ItemTemplate>
                    


               
             
               
                    
                        <HeaderStyle HorizontalAlign="Center" />
                        <ItemStyle HorizontalAlign="Center" />
                    


               
             
               
                    
                    </asp:TemplateField>













                           <asp:BoundField DataField="UserName" HeaderText="From"
                    SortExpression="UserName" />

                    
              <asp:BoundField DataField="Subject" HeaderText="Subject"
                    SortExpression="Subject" />

                <asp:BoundField DataField="Body" HeaderText="Body"
                    SortExpression="Body" Visible="False" />
                <asp:BoundField DataField="ArtistId" HeaderText="ArtistId"
                    SortExpression="ArtistId" Visible="False" />
                <asp:BoundField DataField="UserId" HeaderText="UserId"
                    SortExpression="UserId" Visible="False" />
              
              
              
                <asp:TemplateField HeaderText="Received" SortExpression="Date">
                    <EditItemTemplate>
                        <asp:TextBox ID="TextBox1" runat="server" Text='<%# Bind("Date") %>'></asp:TextBox>
                    </EditItemTemplate>
                    <ItemTemplate>

                       <asp:Label ID="DateLabel" DataFormatString="{0:d}" HtmlEncode="false" runat="server" Text='<%# ((DateTime)Eval("Date")).ToString("MMM d, yyyy") %>'  />
             

                    </ItemTemplate>
                </asp:TemplateField>
            
              
          
     
                      
                     <asp:TemplateField HeaderText="Details">
                         <ItemTemplate>


                               <asp:HyperLink ID="HyperLink2" runat="server" class="btn btn-success btn-xs pull-left"
                                 NavigateUrl='<%# Eval("EmailId" xxxxxxxxxxxxxx.aspx?EmailId={0}  ") %>'
                             Text="View >>"></asp:HyperLink>


                         </ItemTemplate>
                </asp:TemplateField>






                  
            </Columns>
        </asp:GridView>










     

        <script type="text/javascript">
            $(function () {
                $('[id*=GridView1]').footable();
            });
        </script>
        


                               
           
        <br /><br />

    Tuesday, August 4, 2015 8:22 AM

All replies

  • User1724605321 posted

    Hi prontonet ,

    "a script on this page may be busy or it may have stopped responding

    According to your code ,you don't use any ajax control , and are you getting this error in all the browsers or in a particular browser? I would suggest you to check the same using Internet Explorer and check if the issue persists. That is known issue in Mozilla, please look into this discussion :

    https://support.mozilla.org/en-US/kb/warning-unresponsive-script?redirectlocale=en-US&redirectslug=Warning+Unresponsive+script .

    http://forums.asp.net/t/1927520.aspx 

    http://forums.asp.net/t/1832528.aspx

    Best Regards,

    Nan Yu

    Tuesday, August 4, 2015 10:39 PM
  • User-631683198 posted

    yes that's right i am not using ajax on that particular page.

    Its also happening using Chrome browser and the page is super slow when opening

    Could you confirm what should be in the BIN file on the server

    after downloading the latest ajax toolkit release

    is it just the

    AjaxControlToolkit.dll

    AjaxControlToolkit.dll.refresh

    Wednesday, August 5, 2015 12:54 PM
  • User-631683198 posted

    as the problem started occuring after I deleted the old toolkil.DLL and

    replaced it with new I assume its has something to do with that

    Wednesday, August 5, 2015 12:55 PM
  • User1724605321 posted

    Hi prontonet ,

    as the problem started occuring after I deleted the old toolkil.DLL and

    replaced it with new I assume its has something to do with that

    I would suggest you could update your ajax control toolkit to latest version in vs and re-publish to your server .

    Best Regards,

    Nan Yu

    Thursday, August 6, 2015 4:43 AM