none
People Search - no results returned RRS feed

  • Question

  • I have SharePoint Server 2010 installed on a Win2k8R2 server, AD is also installed. I have created some accounts in AD and successfully imported them into the profile database. I have created a site to host the My Site Host template and have successfully browsed to the site and can see each of the users details and can use the organisation browser (I set up a simple hierarchy for the users using the manager field in AD).

    I have logged in as each of the users, edited some details (such as Name, added a photo) and I have carried out some simple operations as each person (tagged a page, left a note on another user's board etc.).

    I have created site using the Enterprise Search template, I have done a full crawl of all of my sites and I can successfully search for stuff.

    The issue I have is that the people search (from both the my site host site and the enterprise search site) does not return any people.

    Any comments appreciated.

    Cheers,

    Colin
    • Moved by Mike Walsh FIN Thursday, November 26, 2009 12:23 PM admin until a search forum is available (From:SharePoint 2010 - General Questions and Answers)
    Thursday, November 26, 2009 12:18 PM

Answers

  • Hmm, when I read your thread, I had my farm working with UserProfileSync pulling from AD nicely and properties filled out for users, but I hadn't done a crawl nor setup a search site, so I did all the steps you mentioned, and after a full crawl, I got results right away when doing a People search (regular search works, too).  Go to your concent source and be sure it includes the link for sps3:http://<URL>.  Also, be sure your People scope is populated.
    SharePoint Architect || My Blog
    • Marked as answer by Colin Rippey Thursday, November 26, 2009 10:53 PM
    Thursday, November 26, 2009 9:24 PM

All replies

  • Hmm, when I read your thread, I had my farm working with UserProfileSync pulling from AD nicely and properties filled out for users, but I hadn't done a crawl nor setup a search site, so I did all the steps you mentioned, and after a full crawl, I got results right away when doing a People search (regular search works, too).  Go to your concent source and be sure it includes the link for sps3:http://<URL>.  Also, be sure your People scope is populated.
    SharePoint Architect || My Blog
    • Marked as answer by Colin Rippey Thursday, November 26, 2009 10:53 PM
    Thursday, November 26, 2009 9:24 PM
  • Hi Clayton,

    Your pointer to sps3:// did the trick. When I created the farm, I opened up Central Admin and ran the wizard. At the Create Site Collection step in the wizard I didn't bother creating a site collection. Afterward I created a set of web applications (all on port 80 using host headers) and then created site collections on them. So, what I had was a web application with the local server name on port 80 but with no site collection at the root.

    In search administration the default content source "Local SharePoint Sites" had a set of start addresses all pointing to the root of each web application, the only one which has the protocol sps3 was the web application with the local machine name.

    I had noticed in the crawl logs that I was getting an error on the sps3://<localmachinename> start address but just put it down to not having a site collection at the root of the site, I never connected the fact that people search was not working. After closer inspection of the http://<localmachinename> web application I can see that a site collection was created at http://<localmachinename>/my which is of course using the My Site Host template.

    I had created a site at http://my.2010.sp.dev using the My Site Host template and configured the My Sites to use this as the My Site Host location.

    So, what I did was to create a site collection at the root of the http://<localmachinename> web application and re-run the crawl. Voila, I can now get people back in my search results.

    As an aside, when I was experimenting with the settings trying to get things working I did also add into the content source web addresses sps3://my.2010.sp.dev and do a full crawl. In this scenario I get back 2 identical results for each people search I do. Both search results point to http://my.2010.sp.dev web application.

    So, I now have people search working. I guess what I have learned now is that people crawls are done using the sps3 protocol.

    Cheers,

    Colin
    Thursday, November 26, 2009 10:52 PM
  • Right on.  So, does this mean that all your host headers are working fine?  When I try to add an alternate access mapping for my existing web app with a new host header (as opposed to the machine name that I set as default), it will never let me authenticate, although I can get to it anonymously if I turn those settings on.  Did you have no issues, and did you set the host header right away upon creation of the web app?  I'm going to post a new thread on this with all the details, too.
    SharePoint Architect || My Blog
    Thursday, November 26, 2009 11:18 PM
  • Hi Clayton,

    Have you disabled the loopback check to allow you to browse to local sites with host headers:

    http://www.harbar.net/archive/2009/07/02/disableloopbackcheck-amp-sharepoint-what-every-admin-and-developer-should-know.aspx

    Cheers,

    Colin
    Friday, November 27, 2009 12:14 AM
  • Thanks.  That counts as a "duh" moment.  That's all I needed to do.
    SharePoint Architect || My Blog
    Friday, November 27, 2009 12:28 AM