none
No strCache/numCache if two different series types RRS feed

  • Question

  • This is occurring in my PowerPoint AddIn but it's chart code so posting here. I have a COM (not VSTO) AddIn.

    If I populate 3 series that are all already a barChart (dir=col), by setting the values in the Worksheet.Cells and then setting Series.Name, XValues, & Values to the formula for each series' data, it all works great.

    Now if I add 3 series of type lineChart and do the same thing setting the WorksheetCells and Series.Name, XValues, & Values I get a blank chart. If I save it the chart.xml is all correct, but it is mussing the strCache/numCache parts. And for the X values, it has multiLvlStrRef instead of strRef.

    I do not set values in the Series.Points, just the data and the formula as that has been sufficient elsewhere. Should I be setting that too? And if I do, do I then not set it in the worksheet? Or if all three, does it need to be in a specific order?

    I can code up a sample if needed, but I am hoping this is a know issue, hopefully with a work-around and so the description above is sufficient.

    Any idea what's going on here. Is there something I need to do to have it populate the strCache/numCache parts?

    thanks - dave


    What we did for the last 6 months - Made the world's coolest reporting & docgen system even more amazing

    Monday, December 17, 2018 5:33 PM

All replies

  • It's a while since I've looked at charts in PowerPoint, however if you want replies from PPT experts you'll probably need to give a lot more information with clear details of what you're actually doing, at least I don't follow!

    Are you saying you created a chart, linked it to ppt, then added more series...? If so try deleting the ppt chart, modify the Excel chart to suit, then relink back to a new ppt chart. Only of a guess!


    Tuesday, December 18, 2018 8:02 PM
    Moderator