none
New flight 15007 released for Insiders

    General discussion

  • We have released a new flight with the build number 15007 for Insiders. If you discover any issue, please report it using the feedback app.

    New this build:

    • Changes were made to the GUID of the UEFI file system volume for the DragonBoard
    • Updates were made to Cortana on IoT to address reports of errors when listening
    • Changes were made to the visual layout of Windows Devices Portal (WDP/Web Management)
    • The Dragonboard BSP in the provided FFU has been updated to build 2110 as provided by Qualcomm
    • The Windows Device Portal (WDP/Web Management) has been extended to add a quick run portal for IoT Samples
    • A fix was made to the Class Extensions for Hardware Notification (hwnclx) and USB Function (usbfnclx) packages so that they would be included in the default IoT Core images
    • Changes were made to IoTShell to enable waiting for PPKG provisioned package installation to complete.
    • Updates were made to the GPIO Interrupt Buffer API
    • Changes were made to Applyupdate.exe to add the blockrebooton/blockrebootoff flags
    • A fix was made to the power state API to ensure the wakeup timer is cancelled upon exiting from connected standby
    • Universal Write Filter (UWF) has been added as an option to the Windows Imaging and Configuration Designer (ICD)
    • The BluetoothLE stack has been updated to address the issues seen when calling GattDeviceService.GetCharacteristics
    • Issues with NanoRDP connecting have been addressed
    • Fix issue where Cortana was dismissed even when set as the default app.
    • Improvements to enable Device Guard functionality.
    • Update IoT to comply with "IoT Device Wi-Fi Beacons Partner Spec". This change allows IoT devices to be discoverable and on-boardable from Windows 10 RS2 Desktop images from "Settings->Devices->Connected Devices->Add Devices”
    • Improvements to allow changing languages (including On-Screen Keyboard functionality).
    • Improvements to Cortana ambient mode.
    • Improvements to the “Windows Update” page in Windows Device Portal to show the correct update status in some instances where “downloading updates” was incorrectly displayed. 
    • Update IoTCoreAudioControlTool to allow users to select the default render or capture endpoint from the command line.
    • Fix to keep the app package version up to date after inbox servicing.
    • Fixes to prevent IoT Core from getting stuck in OOBE due to a crash on the first boot.
    • Added option in Windows Device Portal on the App Page and a command line option in the DeployAppx tool  to check for store updates.
    • Updated IotCoreDefaultApp (Bertha) with Cortana Voice Activation functionality.
    • Enable the app update policy on IoT Core  (ApplicationManagement/AllowAppStoreAutoUpdate).
    • Allow launch to AboutMe from URI On IoT devices to enable the user to disassociate their MSA from Cortana.
    • Vibration WinRT API updates.
    • Namespace change for some Haptic control APIs
    • Enable Port Proxy on IoT Core.
    • Vibration API updates and bug fixes.
    • Fix issues with NanoRDP which caused NanoRDP to fail in some instances.
    • The package version mismatch has been fixed

     

    Known issues:

    • The MinnowBoard Max firmware 0.93 has a known issue which can lead to network connectivity failure
    • BluetoothLE paired devices may throw and exception and fail to function properly
    • Raspberry PI images may crash on their first boot. Consecutive boots start up correctly
    • MSA Logi fails

    Thanks!

    Thursday, January 12, 2017 11:47 PM
    Moderator

All replies

  • On PIs:

    After the last update, the web pages contain only static data so .. I don't know what version is running :-D

    Another PI, that was running the standard version - NOT insider - after the last update ... it is gone (RIP).

    Please, please, please ... try to do something working !! you can ! I am sure .. YOU CAN .. believe in you !  

    Regards,

    CAP

    Friday, January 13, 2017 2:00 PM
  • CAP, are you using Microsoft Edge? Since 15002, you need to use Microsoft Edge to address the web portal, Google Chrome is no longer supported. Firefox only works partially..... It may take a wile before all the info is displayed, you may even have to restart both the Pi and your computer... (i had to).

    Anne



    Friday, January 13, 2017 2:19 PM
  • Thx Anne, yes i am using Edge and it does not work but .. i have tried Explorer and its Works :-D :-D

    So now i know that RPI has f. 15002.1001 and is updating .. to new surprises and beyond ..

    ACCIDENTI ! 

    Friday, January 13, 2017 2:31 PM
  • Found what I think is an issue with Keyboard layout and the on screen keyboard?

    I changed the basic preferences on the device to have a keyboard layout of English (United Kingdom), when trying to use the on screen keyboard it still says <ENG (US)> in the space bar but when I press the @ key it displays the " character and if I press the " key it displays the @ character.

    I would have expected the on screen layout to just be changed to match UK layout rather than to transpose the US keys onto the UK mappings?

    Feedback link https://aka.ms/L4yphq

    Sunday, January 15, 2017 8:47 PM
  • My pi isn't booting up when i set resolution to 800x600. when I try to boot up my pi red and green led stays on and pi doesn't boot up. If i take sd card out and edit config.txt file resolution to anything else then 800x600 it works again.Any fix guys?  
    • Edited by gourabSH07 Monday, January 16, 2017 4:02 PM
    Monday, January 16, 2017 4:02 PM
  • @gourabSH07

    did you report it using feedback hub as mentioned?

    Monday, January 16, 2017 4:15 PM
    Moderator
  • yes i did 
    Tuesday, January 17, 2017 5:04 AM
  • great
    Tuesday, January 17, 2017 11:26 AM
    Moderator
  • https://aka.ms/Gle70m
    Tuesday, January 17, 2017 12:07 PM
  • For the past few builds, It's been impossible to do anything meaningful. My RPi3 currently was in the process of finishing the update to 15007, but it's stuck booting up or something. Solid green Solid red LEDs. Same issue on the build before that and the one before that.

    I've reflashed 14986 (actually 14393 based on the .ffu)

    The device portal is useless with these past builds. Only gets partially useful when using InPrivate tab on Edge.

    When is this going to be functional again?

    • Merged by IoTGirlModerator Monday, January 30, 2017 5:52 PM Version specific issue
    Sunday, January 29, 2017 12:53 AM
  • I have reflashed and updated several Pi2 and Pi3 without problems, make sure to leave it on during first boot it will sometimes take more than an hour (have it connected to a monitor via hdmi helps). Switching it off during the update corrupts the installation and you have to start again with a new reflash.

    If this does not work replace the sd card. Pi3 also need a better power supply so make sure you do not use an old mobile charger for this

    Yes the device portal only works with Edge (for some strange reason)


    • Edited by karlssja Sunday, January 29, 2017 6:32 AM
    Sunday, January 29, 2017 6:30 AM
  • Hi Carlo & Karl,

    Please use the feedback app for version specific feedback.  Those issue get routed directly to the team for review and that allows for faster processing that posts within this forum.  I have merged you version specific issue into the post regarding the version itself as that also should get it review but again, not as efficient as using the feedback app.

    Sincerest thanks,

    IoTGirl

    Monday, January 30, 2017 5:57 PM
    Moderator