locked
Package identity name messed up RRS feed

  • Question

  • Hi,

    After more than two weeks of discussions with the Marketplace publishing support I finally got the mail today that they do not know how to fix this... So I give it a second try here:

    I recently converted my Windows Phone 8 app "SampleApp" to Windows Phone 8.1 Silverlight. I also registered an app name in the publisher interface which returned a Package identity name of the form "abcdefg.53154C2F388DB". The part "53154C2F388DB" looks strange because usually (with other apps I have converted) this id equals the app name (e.g. "abcdefg.SampleApp").

    When I enter this id "abcdefg.53154C2F388DB" in the "Package.appxmanifest" file then the XAP cannot be deployed with the following error (even on a completely resetted device): "Install failed. Please contact your software vendor".
    When the id is changed from "abcdefg.53154C2F388DB" to "abcdefg.SampleApp" then deployment works but uploading the XAP in the publisher portal fails with this error: "The package identity associated with this update doesn't match what's in the uploaded package: "abcdefg.SampleApp" ".

    For other apps which I converted from WP 8 to WP 8.1 the publisher portal always returned an ID like "abcdefg.MyAppName", except this app. So, I think that the system generated a wrong ID for this app? How can I fix the problem?

    Regards,


    • Edited by SyFr Tuesday, September 16, 2014 5:50 AM typos
    • Moved by Jonathan S - MSFT Friday, September 26, 2014 2:54 PM Moved to tools for WP development
    Tuesday, September 16, 2014 5:49 AM

All replies

  • Hello,

    My first suggestion would have been to rebuild the app package. Since you were working with support they may have suggested that already. Can you provide your ticket number? 

    Thanks,

    Jonathan


    Windows and Windows Phone Dev Center Support

    Office Store Developer Support

    Send us your feedback about the Windows Platform


    Wednesday, September 24, 2014 12:35 AM
  • When you enter in to Package.appxmanifest, do you do so through the GUI editor to that file? I have found that sometimes I have to also view the raw XML behind the file and tweak it in some instances. Might want to check that out.

    http://about.me/bc3tech

    Wednesday, September 24, 2014 1:03 AM
  • Hi,

    I manually changed the id in the "Packaga.appxmanifest" here:

     <Identity Name="abcdefg.53154C2F388DB" Publisher="CN=xyz" Version="1.0.0.0" />

    I also cleaned the whole solution but this did not work either.

    My support id is: SRX1260542758ID

    Regards,

    Wednesday, September 24, 2014 4:55 AM
  • Thanks for posting the support ID. Can you see what is listed in the WMAppManifest.xml? If it's different than what is in Package.appxmanifest, you may want to try changing that, too so they match.

    -Jonathan


    Windows and Windows Phone Dev Center Support

    Office Store Developer Support

    Send us your feedback about the Windows Platform

    Friday, September 26, 2014 12:04 AM
  • The problem can be easily reproduced:

    1.) Create a new Windows Phone Silverlight 8.1 project in Visual Studio 2013 (Update 3).

    2.) Run the project on a real device (debug or release does not matter). Everything works. Do NOT uninstall the app.

    3.) Change Package.appxmanifest:

      <Identity Name="30051teq-IT.53154C2F388DB" Publisher="CN=AF57582D-6260-4331-A170-44303FB793CE" Version="1.0.0.0" />


    4.) Run the app again on the device -> Ok.

    5.) Uninstall the app form the device and try to run it again -> Failure: "Install failed. Please contact your software vendor"


    When changing the identity name slightly, for instance "30051teq-IT.53154C2F388AB" or "30051xyz-IT.53154C2F388DB" then running on the device works again.


    Friday, September 26, 2014 12:00 PM
  • Thanks for the updated info with these repro steps. I'll keep tracking this thread, but I'm going to move this to the technical forums for them to weigh in on this.

    -Jonathan


    Windows and Windows Phone Dev Center Support

    Office Store Developer Support

    Send us your feedback about the Windows Platform

    Friday, September 26, 2014 2:53 PM
  • I could not reproduce the problem you describe.

    What is the OS version on the device you are using to test this?


    Eric Fleck, Windows Store and Windows Phone Developer Support. If you would like to provide feedback or suggestions for future improvements to the Windows Phone SDK please go to http://wpdev.uservoice.com/ where you can post your suggestions and/or cast your votes for existing suggestions.

    Friday, September 26, 2014 5:35 PM
  • Please try this example project: "https://onedrive.live.com/redir?resid=87302167C5D59672!4042&authkey=!AAthXezXjxWBS1g&ithint=file%2czip"
    Friday, September 26, 2014 6:25 PM
  • I had no problem deploying that project to my phone either... are there extra steps I need to perform when using this project in order to reproduce the problem?

    FWIW: The device I'm testing on has the latest developer preview OS build: 8.10.14176.243.


    Eric Fleck, Windows Store and Windows Phone Developer Support. If you would like to provide feedback or suggestions for future improvements to the Windows Phone SDK please go to http://wpdev.uservoice.com/ where you can post your suggestions and/or cast your votes for existing suggestions.

    Friday, September 26, 2014 8:14 PM