locked
Cannot debug Unit Tests RRS feed

  • Question

  • I have VS2008 Team Ed. for Testers.  I was successfully debugging unit tests earlier today, but now I can't.  I select Test -> Debug -> Tests in Current Context.  Then:

    The Visual Studio development Web server starts (is that normal?)

    The test runs, but break points are not hit.

    Restarting VS2008 didn't help.


    It may have started when this happened to me:

    I was stepping through a unit test.
    I edited the unit test and tried to use the "edit and continue" feature.
    VS2008 said I could not do that and must restart.
    I told it to restart.
    Instead of re-running (and debugging) the unit tests, it tried to run my web app.
    I stopped the web app.

    Now I can't debug unit tests.

    Is there something I can clear or reset?

    Chris

    Thursday, March 26, 2009 7:39 PM

Answers

  • Ok, I fixed it. Running

    devenv /resetuserdata

    Did the trick.
    • Marked as answer by Bill.Wang Monday, March 30, 2009 6:52 AM
    Thursday, March 26, 2009 8:02 PM

All replies

  • Ok, I fixed it. Running

    devenv /resetuserdata

    Did the trick.
    • Marked as answer by Bill.Wang Monday, March 30, 2009 6:52 AM
    Thursday, March 26, 2009 8:02 PM
  • Glad you got it to work. Thanks for sharing your solution. It will be very helpful when others meet the similar issue. 
    Please mark the replies as answers if they help and unmark them if they provide no help.
    Monday, March 30, 2009 6:52 AM