locked
404 error after deploying my website RRS feed

  • Question

  • User2055999601 posted

    I just uploaded my website to my server, and I keep getting this error:

    "The page cannot be found

    HTTP Error 404 - File or directory not found."

    You can see this error at http://www.mm-theory.com.

    I'm running IIS 6 on Windows Server 2003. In the properties of the website, under Documents, I have nuts_and_bolts.aspx at the top of the list. nuts_and_bolts.aspx certainly exist in the root directory. I have it pointing to my root directory under Home Directory. I have all permissions set for everyone.

    Why would it say the file or directory is not found?

    Thursday, January 17, 2013 9:42 PM

Answers

  • User2055999601 posted

    All of a sudden, it's working (magic I guess).

    I have Default.asp and Default.htm in the list, but nuts_and_bolts_aspx is at the top of the list. Shouldn't that make nuts_and_bolts.aspx accessable

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, January 19, 2013 11:54 AM

All replies

  • User1759999623 posted

    Do you have a Default.aspx file?  If not, then you likely do not have a default page for your website.  Try either changing the name of your main page to Default.aspx or add the file's name to your default page list in IIS.

    Thursday, January 17, 2013 10:13 PM
  • User13850534 posted

    The url http://www.mm-theory.com/nuts_and_bolts.aspx gives different error. Can you switch your website to another application pool and see if it's working?

    Friday, January 18, 2013 4:20 AM
  • User2055999601 posted

    All of a sudden, it's working (magic I guess).

    I have Default.asp and Default.htm in the list, but nuts_and_bolts_aspx is at the top of the list. Shouldn't that make nuts_and_bolts.aspx accessable

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, January 19, 2013 11:54 AM