locked
http://localhost/CertSrv file not found error... RRS feed

  • Question

  • User-853351690 posted

    Ok...  I've been looking at different web-sites for HOURS now, and I just can't find the solution to this problem...

    On my Windows Server 2003 R2 (SP2) computer, I installed Certificate Services from the Control Panel.  I can run the Certificate Services MMC insert -- that works and shows absolutely no certificates have been issued or revoked (as you'd expect from a brand-new CA installation).

    IIS was installed and running before I installed Certificate Services.  From a command prompt, 'certutil -vroot' tells me that all the virtual directories are already installed.

    When I run the IIS manager, it shows that CertSrv is a valid web page.  I look at it, and all the files, including default.asp are all in there.

    Yet STILL http://localhost/CertSrv gives me a "404 Page Not Found" error.  It's just not finding it.  WHY??!?!??!?!?!?!!

    I'm about ready to throw this computer through a damn window!

    I'd really appreciate some help here.  Thanks.

    Laurence MacNeill, Mableton, Georgia, USA.

    Thursday, February 11, 2010 5:44 PM

All replies

  • User-823196590 posted

    Start here so we can get a better idea why there is a 404:

    http://blogs.iis.net/tomkmvp/archive/2009/04/27/troubleshooting-a-404.aspx

    Thursday, February 11, 2010 7:21 PM
  • User-853351690 posted

    I did that -- it's returning a 404.0 error.  Look that up on the website linked in that article and that apparently means "(None) - File or Directory Not Found."  LOL  Already knew that one.

    Wednesday, February 17, 2010 4:28 AM
  • User-823196590 posted

    When I run the IIS manager, it shows that CertSrv is a valid web page.  I look at it, and all the files, including default.asp are all in there.

    What physical path is this mapped to?

    Do you have more thna one web site on this server?

    Wednesday, February 17, 2010 11:38 AM
  • User-853351690 posted

    It is mapped to C:\WINDOWS\system32\CertSrv

    I've checked that folder, and yes the files all appear to be there, including default.asp, which is the file that should be loading when you go to http://localhost/CertSrv, yes?

    EDIT:  Oh yeah -- I only have 1 website, the Default Web Site.  It has many folders in it, but that shouldn't make a difference, right?

    Wednesday, February 17, 2010 6:08 PM
  • User-853351690 posted

    Ok -- I've never had great luck with this web server, so I figured I'd just wipe it and re-install everything from scratch...  Formatted the hard drive, re-installed WinServer2003, re-installed IIS, re-installed Certificate Services.  http://localhost/certsrv worked fine.  Yay!

     Now the problem.  It's back.  BUT -- I think I know what killed it.  I just need a little help fixing it.  The problem re-occurred when I installed MS SQL Server 2005.  I need the reporting services, and the reporting services wouldn't install unless I enabled 32-bit ASP.  CertSrv (I'm guessing) wants 64-bit ASP.  64-bit and 32-bit ASP cannot run at the same time (I think?).  Anyway -- it was after I installed SQL Server 2005 that the problem came back.  And now, it's here permanently, apparently -- whatever SQL 2005 did to my IIS setup, it's destroyed CertSrv permanently now.  I can disable 32-bit ASP and re-enable 64-bit ASP, but the problem doesn't change.

    However, after enabling and disabling ASP so many times, now CertSrv is telling me Service Unavailable instead of File Not Found...  So it just gets better and better...

    Can anyone PLEASE help me figure out how to run SQL Server 2005 reporting services and CertSrv on the same server.  Thanks.

     EDIT:  Ok, I uninstalled Reporting Services on SQL Server 2005, uninstalled Certificate Services, uninstalled IIS.  Then I re-installed IIS and Cert Services.  CertSrv is now working again.  But I don't have SQL Server's Reporting Services, which I need.  So I still need some help getting 32-bit Reporting Services running without ruining the CertSrv...  If anyone knows how to do that, I'd be very grateful for your help.  Thanks.

    EDIT2: Well, the problem seems to occur when I install ANY 32-bit stuff on 64-bit IIS. (32-bit ColdFusion 8 killed CertSrv just as neatly as 32-bit SQL Reporting Services...)  So if anyone knows how to get 32-bit IIS running on a 64-bit version of WinServer 2003, I'd appreciate that info.  Thanks.

    EDIT3:  So, it seems, based on the reasearch I've done, that a 64-bit OS cannot run 32-bit IIS at all?  The only way to run 32-bit apps that need IIS to work is to set IIS in 32-bit mode, and that kills all the 64-bit stuff on there (like CertSrv...)  So, looks like I'm gonna have to buy a 64-bit copy of ColdFusion and SQL Server...  Fun, fun...  NOT!

    Thursday, February 18, 2010 4:28 AM
  • User826544435 posted

    i don't remeber how on 2003, but on 2012 you have to install additional feature:

    Saturday, December 26, 2015 9:19 AM
  • User397924297 posted

    I know this thread is old, but I think what you wanted was this command, which you run on a comand line from within the C:\inetpub\adminscripts directory:

    cscript.exe adsutil.vbs set W3SVC/AppPools/Enable32BitAppOnWin64 “true”

    I believe you can also swap "AppPools" for the identifier for your site in IIS, i.e. DefaultWebSite = 1, but any other site will have some weird long numeric ID about 10 digits long, I believe, if you just want it for a particular site.

    Reference:  https://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/405f5bb5-87a3-43d2-8138-54b75db73aa1.mspx?mfr=true

    Monday, April 17, 2017 8:38 PM