none
Not able to create Trading Partner profile in Trading Partner management RRS feed

  • Question

  • I am just getting started with Logic Apps and we are looking at b2b processes. It looks like I have the TradingManagement API configured correctly but when I try to add a sample partner. I went through a couple of iterations of recreating the API and database with the same result. 

    TITLE

     

    Error creating a partner
    DESCRIPTION
     
    There was an error creating a partner with name 'Bill Test' in 'TradingPartnerManagement'. Error : 'There was an error encountered. Please retry or contact support.'
    STATUS
     
    Error
    TIMESTAMP
     
    Wed Feb 24 2016 09:21:36 GMT-0600 (Central Standard Time)
    UTC TIMESTAMP
     
    Wed, 24 Feb 2016 15:21:36 GMT
    CORRELATION IDS
     
    77be1114-8855-4d87-9e8b-b81098c5fff8

    Wednesday, February 24, 2016 3:22 PM

Answers

  • Hi,

    Can you check whether DB Connection string is configured in the APP Settings of TPM API APP Host? If not, please add the db connection string.

     

    eg:

    DbConnectionString : Data Source=tcp:testserver.database.windows.net;Initial Catalog=testdb;Integrated Security=False;User ID=sqladmin@testdb;Password=testpassword;Asynchronous Processing=True;Encrypt=True;TrustServerCertificate=False

     

    If the DB connection string is configured and you are still facing the issue, please send us the TPM API APP Host name and time period when you tried the operation. We will look into the logs

    .

    Saturday, February 27, 2016 10:27 PM

All replies

  • Thanks I've reached out to others to help with this.
    Thursday, February 25, 2016 12:10 AM
    Moderator
  • Hi,

    Can you check whether DB Connection string is configured in the APP Settings of TPM API APP Host? If not, please add the db connection string.

     

    eg:

    DbConnectionString : Data Source=tcp:testserver.database.windows.net;Initial Catalog=testdb;Integrated Security=False;User ID=sqladmin@testdb;Password=testpassword;Asynchronous Processing=True;Encrypt=True;TrustServerCertificate=False

     

    If the DB connection string is configured and you are still facing the issue, please send us the TPM API APP Host name and time period when you tried the operation. We will look into the logs

    .

    Saturday, February 27, 2016 10:27 PM
  • I was having the exact same issue. It seems that the setup process is not copying the connection string into the api app settings. If you enter it manually it does solve the problem.



    • Edited by jeremys777 Thursday, March 10, 2016 10:56 PM
    Thursday, March 10, 2016 10:53 PM
  • Hi All,

    I tried to add database connection manually as property was empty. Unfortunately save option does not work when I update or add application settings. Is there any tick on how we update the application settings manually.

    Monday, June 6, 2016 2:09 PM
  • I ran into same issue and had ticket open with Microsoft. I was told that the bug was fixed as part of release that's happening tomorrow.

    Alternatively, I have been using ARM template for all my deployments and it's been working great with that.  Let me know if you need help on ARM template

    Tuesday, June 7, 2016 2:35 AM