none
WCF, WMI and last microsft security update for Windows 10 RRS feed

  • Question

  • Hi,

    We are using WMI to activate the WCF traces of one of our application. Before the Microsoft security update KB4025344, everything was fine. Since the update, we have to run our application as administrator to allow the WMI provider of WCF to be registered. Our users won't be happy with that. Anybody knows if this change was intentional ? If so, what can we do beside running the application as administrator?

    Thanks you

    JMR 

    Tuesday, August 1, 2017 7:24 PM

All replies

  • Hi JMR,

    >> we have to run our application as administrator to allow the WMI provider of WCF to be registered

    Could you share us more information about your application and how does it allow WMI provider?

    KB4025344 change security updates to IE 11, I suggest you try to set run IE as an administrator with backwards compatibility set to IE 9.

    Or, I suggest you try PowerShell script to use WMI.

    # Troubleshooting WCF Services during Runtime with WMI

    https://blogs.msdn.microsoft.com/mvpawardprogram/2014/02/24/troubleshooting-wcf-services-during-runtime-with-wmi/

    Best Regards,

    Edward


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, August 2, 2017 1:55 AM
  • Our application is a self-hosted WCF webservice server. It runs as a Windows Service. We cannot ask our customers to run it “as Admin”  in a production context to activate tracing.

    We use an external (w/ regards to our server ) application to activate WCF tracing through WMI. That application runs “as admin”.

    We activate WCF traces using the .Net ManagementClass API. We do that first by enumerating all the instances of the "\Root\ServiceModel\AppDomainInfo” namespace to find the instances related to our process then setting the WCF related properties:

    • traceLevel
    • logMessagesAtTransportLevel
    • logMalformedMessages

    Prior to KB4025344 the enumeration part used to be functional. After KB4025344, we cannot find our process instance anymore.

    Our server’s configuration file contains the following:

    <system.serviceModel>

         <diagnostics wmiProviderEnabled="true">

            <messageLogging logEntireMessage="true"

                            maxMessagesToLog="-1"

                            maxSizeOfMessageToLog="2147483647"/>

         </diagnostics>

    ...

    Hoping that this informations help.

    Thanks

    Wednesday, August 2, 2017 1:53 PM
  • Hi JMR,

    >> We do that first by enumerating all the instances of the "\Root\ServiceModel\AppDomainInfo” namespace to find the instances related to our process then setting the WCF related properties

    It seems failing to find the instance make your application down.  Could you check whether the instance real exist, but your code did not find it or the instance did not start correctly?

    Per to your description, it seems to be related with privileges, I suggest you try below link to assign privileges.

    # C# WMI privileges

    https://stackoverflow.com/questions/6535216/c-sharp-wmi-privileges?rq=1

    Best Regards,

    Edward


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, August 3, 2017 2:59 AM