none
Problems with mySAP Adapter 3.0 RRS feed

  • Question

  •  

    Hi

    I have configued a receive port that receive Idoc from SAP. The configuration was ok.

    When i try to start receive port with a receive location that is binding with SAP enviroment, the port go in disable and i see the next error message:

     

    The Messaging Engine failed to add a receive location "Test_Receive_Idoc" with URL "sap://Client=400;lang=IT@A/SRVSAP01/01?GwHost=SRVSAP01&GwServ=SAPGW01&ListenerProgramId=TS6" to the adapter "WCF-Custom". Reason: "Microsoft.ServiceModel.Channels.Common.ConnectionException: Details: ErrorCode=RFC_OK. ErrorGroup=RFC_ERROR_COMMUNICATION. SapErrorMessage=SAP_CMINIT3 : rc=20 > Connect to SAP gateway failed
    Connect_PM  GWHOST=SRVSAP01, GWSERV=SAPGW01, SYSNR=01

    LOCATION    CPIC (TCP/IP) on local host with Unicode
    ERROR       service 'SAPGW01' unknown

     

    where is the error ? SAP side or BT?

     

    Thanks in advance

    Best regards

     

     

    Wednesday, October 29, 2008 8:21 AM

Answers

  • The URI should be:

     

    sap://Client=400;lang=EN@A/SRVSAP05/01?ListenerGwHost=srvsap05&ListenerGwServ=sapgw01&ListenerProgramId=TS6

     

    Saturday, November 8, 2008 6:27 PM

All replies

  •  

    Hi, I assume you already checked your connection URI. Would it be possible to install SAP GUI and see if this solves the issue?
    Wednesday, October 29, 2008 4:15 PM
  • Hi, edit your hosts file like this: sapgw01 3301 tcp
    Wednesday, October 29, 2008 9:13 PM
  • Hi

    i have tried but not working. I'waiting to install the SAP GUI and i'm reading the error message. I have found the error partner '10.1.2.20:3301' not reached!! But the IP address 10.1.2.20 not is the IP addres of SRVSAP05 the AHOST that i have index ... how can solve this configuration?

    Thanks in advance

     

    Thursday, October 30, 2008 2:08 PM
  •  

    Not sure I understand your last message. Perhaps some firewall setting is blocking your connection?
    Thursday, October 30, 2008 2:51 PM
  • Hi Stefan

    the last error was for a bad configuration SAP side ... Now i have installed the SAP GUI 7.10. I try to establish a SAP connection with a Receive Port and Receive Location and i have the next error:

    Reason: "Microsoft.ServiceModel.Channels.Common.ConnectionException: The parameter Listener Gateway Host required for SAP Inbound Handler was not specified.

    I use the next URI:

    sap://Client=400;lang=EN@A/SRVSAP05/01?GwHost=srvsap05&GwServ=sapgw01&ListenerProgramId=TS6

    the Listener Gateway not is the GwHost=srvsap05?

     

    Thanks in advance

    Thursday, October 30, 2008 3:17 PM
  •  

    Hi Enrico, can you confirm that using SAP GUI the connection is working?
    Friday, October 31, 2008 12:47 PM
  • Hi Stefan

    i think yes because the error message is not about the connection

     

    Monday, November 3, 2008 8:53 AM
  • Hi Stefan

    i have solve it ... thank you for your help. I have wrong the syntax of URI to SAP.

    Best regards.

     

    Tuesday, November 4, 2008 9:45 AM
  • The URI should be:

     

    sap://Client=400;lang=EN@A/SRVSAP05/01?ListenerGwHost=srvsap05&ListenerGwServ=sapgw01&ListenerProgramId=TS6

     

    Saturday, November 8, 2008 6:27 PM