locked
rsAccessDenied Error even though all users are granted ALL Roles (TfsReports on SQL 2014) RRS feed

  • Question

  • User-884282171 posted

    We have granted everyone all roles on our TfsReports site. However, the users still get the following errors when attempting to manage the reports:

    "The permissions granted to user Domain\UserName are insufficient for performing this operation. (rsAccessDenied)"

    These are the roles we've granted to all "Domain Users": Browser, Content Manager, My Reports, Publisher, Report Builder, Team Foundation Content Manager.

    We can't seem to figure out what else might be missing.

    Please help.

    Friday, December 12, 2014 12:00 PM

Answers

  • User1711366110 posted

    Hi anguyen,  
     For your reference, the following steps which is useful to solve your issue:

    Make sure you have access configured to the URL http://localhost/reports using the SQL Reporting Services Configuration. To do this:

      • Open Reporting Services Configuration Manager -> then connect to the report server instance  -> then click on Report Manager URL.
      • In the Report Manager URL page, click the Advanced button -> then in the Multiple Identities for Report Manager, click Add.
      • In the Add a Report Manager HTTP URL popup box, select Host Header and type in: localhost
      • Click Ok to save your changes
    1. Now start/ run Internet Explorer using Run as Administator...  
      • NOTE: If you don't see the  'Site Settings' link in the top left corner while at http://localhost/reports it is probably because you aren't running IE as an Administator or you haven't assigned your computers 'domain\username' to the reporting services roles, see how to do this in the next few steps.
    2. Then go to: http://localhost/reports   (you may have to login with your Computer's username and password)
    3. You should now be directed to the Home page of SQL Server Reporting Services here:http://localhost/Reports/Pages/Folder.aspx
    4. From the Home page, click the Properties tab, then click New Role Assignment
    5. In the Group or user name textbox, add the 'domain\username' which was in the error message ( in your case you can find the domain\username for your computer in the rsAccessDenied error message).
    6. Now check all the checkboxes; Browser, Content Manager, My Reports, Publisher, Report Builder, and then click OK.
    7. You're domain\username should now be assigned to the Roles that will give you access to deploy your reports to the Report Server.  If you're using Visual Studio or SQL Server Business Intelligence Development Studio to deploy your reports to your local reports server, you should now be able to.
    8. Hopefully, that helps you solve your Reports Server rsAccessDenied error message.

    For your reference, this link which helps you to guide the Grant permissions respectively

    Hopefully this will be helpful for you.
    --
    with regards
    Edwin

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, December 15, 2014 1:49 AM