none
Create New MS Team From Group Using PowerShell: Item Not Found Error RRS feed

  • Question

  • Hi

    I'm in the process of scripting the creation of MS Teams using PowerShell. I want to create the associated Group first and then create the Team using the -Group parameter

    New-Team -Group "GUID"

    but this generates an error

    "Failed to execute MS Graph backend request GetGroupInternalApiRequest. The server failed to respond correctly. Response Code: NotFound, Reason: Reason: Not Found".

    I'm getting the GUID from Get-UnifiedGroup -Identity "xxxxxxx". This brings back all the Group properties including GUID

    If I run New-Team -DisplayName "xxxxxx" that works so, as far as I can see, I'm connecting to O35 and running the commands correctly. Has anyone else tried to create Teams from existing Groups using PowerShell and found this problem?

    thanks

    Neil

    Tuesday, September 11, 2018 2:07 PM

Answers

  •  I raised a ticket with Microsoft and it seems that GUID is not the right property to use, it should be  ExternalDirectoryObjectID

    • Marked as answer by Neil Santucci Tuesday, September 18, 2018 11:56 AM
    Tuesday, September 18, 2018 11:56 AM