Specified SAS URL cannot be reached RRS feed

  • Question

  • Issue:

    SKUs>OS VHD URL: warning message shows 

    Specified SAS URL cannot be reached. Ensure that the SAS URL is generated following the instructions at https://docs.microsoft.com/en-us/azure/marketplace-publishing/marketplace-publishing-vm-image-creation#52-get-the-shared-access-signature-uri-for-your-vm-images

    My steps:

    Followed docs virtual-machine/cpp-create-technical-assets  until Step 6 Get SAS URI. 

    More info:

    I generated a SAS URI with Azure CLI without issue, so I assume there's no permission issue on this step. 

    About parameters

    1. AccountName and AccountKey got from my storage accounts -> Access keys
    2. --name xxxxx.vhd
    3. --permissions rl
    4. --start '2019-08-15T00:00:00Z'
    5. --expiry '2019-10-15T00:00:00Z'

    Also confirmed there's a VHD xxxxx.vhd file under my storage account -> XXX - Blobs > vhds 

    p.s. "Change access level" of the vhds folder also not help in my case

    Anything I can look into? the issue stopped me several days still can't figure out. Appreciated for any help 


    Tuesday, August 20, 2019 4:20 PM


All replies

  • Are you using Azure CLI or PowerShell or Storage explorer for generating the SAS URL? There is this GitHub discussion  - https://github.com/Azure/azure-cli/issues/5592 could be helpful fixing your issue.

    Wednesday, August 21, 2019 10:36 AM
  • Hi,

    I was using Powershell ISE to generated the string. Although it's new to me but i don't see any parameter incorrectly. 

    The issue report that you posted seems already fixed in last year?

    Anyway, I tried Microsoft Azure Storage Explore to generate the string and now issue gone...

    Waste times and money but it works now anyway, thanks 

    Wednesday, August 21, 2019 2:57 PM
  • Thanks for the update! Glad to hear it is resolved :)
    Monday, August 26, 2019 12:36 PM