How to configure Visual Studio 2015 to ignore dollar sign in string when selecting words (when using double clicking to select text)?


  • When using Visual Studio 2015 (C++) and double clicking on a string with a dollar sign (e.g. $var), the dollar sign is included in the selection (for copy/paste etc). Can I configure VS to ignore the dollar sign? VS 2010 never included the dollar sign when selecting words.
    Wednesday, June 29, 2016 1:10 PM


  • Hi dave864,

    The behavior in my side is same to yours.

    In VS2015:

    In VS2010:

    I have tried to modify the setting of Visual Studio to not include the $. But I couldn't find out it. I think this is by design in Visual Studio 2015.

    If you feel this behavior in VS2015 is not correct. I suggest that you could submit this feedback to Microsoft Connect feedback portal:,

    Microsoft engineers will evaluate them.

    Best Regards,

    Lake Xiao

    Friday, July 1, 2016 1:37 AM