2738 error code


  • Hello Guys!


    I have a little problem about 2738 error code. I have Vista, and i'd like to install the new Apple browser, but i can't.


    I tried registered at the vbsript.dll, but i can't. The problem is same. Somebody can write it step by step, what can i do?


    Thank you so much!



    Thursday, June 14, 2007 3:00 AM


  • Safari installer relies upon VBScript, which for some reason isn't registered automatically within Vista.
    Try this (worked for me):
    Start button -> All Programs -> Accessories -> Right click on Command Prompt, select 'Run as administrator'.
    You should be in directory C:\Windows\System32
    Type regsvr32 vbscript.dll (enter)
    Should get a message box saying DLL has been registered.
    Run the installer again.
    That worked for me. good luck.
    Thursday, June 14, 2007 9:03 AM

All replies

  • Safari installer relies upon VBScript, which for some reason isn't registered automatically within Vista.
    Try this (worked for me):
    Start button -> All Programs -> Accessories -> Right click on Command Prompt, select 'Run as administrator'.
    You should be in directory C:\Windows\System32
    Type regsvr32 vbscript.dll (enter)
    Should get a message box saying DLL has been registered.
    Run the installer again.
    That worked for me. good luck.
    Thursday, June 14, 2007 9:03 AM
  • Thanks clanceyp. That worked perfect. I appreciate the information.
    Thursday, June 14, 2007 4:05 PM
  • Tnx clanceyp... registering the DLL worked for me, as well. You'd think Apple would know about this! Much appreciated!
    Friday, June 15, 2007 5:29 AM
  • Thanks a lot. It works!


    Note. Under Vista x64 command regsvr32 must be executed from 32-bit application (any file manager, for example). Execution it from Command Prompt didn't work for me

    Sunday, June 17, 2007 11:34 AM
  • Thanks very much the code worked great
    Monday, June 25, 2007 1:31 PM
  • Thank you


    that solved a problem for me as well

    Wednesday, June 27, 2007 8:05 AM
  • Thank you SO much for this post.   I spent hours trying to figure this out yesterday.  It worked like a charm!!  I shared on the apple support site and gave you credit.
    Tuesday, July 03, 2007 12:33 PM

    Thanks very much. I use your info and it work perfect.

    Modesto, CA

    Wednesday, July 04, 2007 1:26 AM
  • that worked great! thank you!
    Wednesday, July 04, 2007 9:17 PM
  • Thanks for your note.  It is the 1st I've found with something about Vista x64.


    I'm having this error but cannot figure out how to execute regsvr32 from other than a command prompt (whcih didn;t work for me either).


    Can you give me some further guidance?



    Thursday, July 05, 2007 4:00 PM
  • that didnt work at all for me and neither did windows script 5.6. microsoft is no help and neither is toshiba. anyone have another answer.
    Friday, July 06, 2007 1:09 PM
  • I discovered in another forum that the key for Vista x64 is to run the 64 bit version of regsvr32.


    to do this run the regsvr32 from C:\windows\sysWOW64


    This finally worked for me & I am now running things that were erroring out before.

    Friday, July 06, 2007 1:21 PM
  • U GOT THAT INFORMATION OFF THE APPLE WEBSITE U CHEATER MUHAHAHAHAH.... LOOK.http://docs.info.apple.com/article.html?artnum=304405
    Friday, July 06, 2007 6:22 PM
  • dude you are the coolest..i was so pissed off with my itunes until i read your message!!


    i decided to try it out and it worked like a charm!!!


    thanks so much!!!!!!!!!!!!!!

    Monday, July 09, 2007 2:01 AM
  • this is obviously a command pompt . can you give me the steps needed to get there.
    Monday, July 09, 2007 3:38 PM
  • thank you this was very helpful


    Tuesday, July 10, 2007 7:49 AM
  • I said I found it at another website and if you knew it was there, why didn't you post the info or a pointer to it?
    Tuesday, July 10, 2007 3:39 PM
  • I go to Start - Accessories - Command Prompt


    Once you have the window type in:


    cd c:\windows\sysWOW64

    regsvr32 vbscript.dll




    This is only slightly different from the previous instructions and only in the directory you set yourself to.


    The 64-bit stuff in sysWOW64 is the key.

    Tuesday, July 10, 2007 3:43 PM
  • Sorry guys, I tried your solution but more erro msg popped up as below:

    The module "vbsript.dll" was loaded but the call to DllRegisterserver failed with error code 0x80004005

    What should I do now??

    thanks, rayliu888
    Tuesday, July 17, 2007 3:00 AM
  • Thank you sooooooo much, I have had that problem for 3 weeks now and finally I found the answer from you, I did it!! Followed your directions and all is well now. Was able to install all programs that before I got the error code 2738......it is GONE...............again thank you.


    Tuesday, July 24, 2007 2:49 AM
  • WDaveE's is the only post on the entire internet that actually fixed my install issue, with Quicktime and Palm Desktop. The solution is using the SysWOW64 folder for Vista 64 bit. If the command prompt is displaying C:\windows\system32, even though the registration may deliver a successful message, the installion programs will continue to error out with code 2738.


    I have been battling this thing for over a month, and NO ONE else advised to use this folder. My thanks to WDaveE!


    Wednesday, August 01, 2007 8:19 AM



    could you elaborate on how to execute this command under x64.  I tried the command prompt as administrator but no success.


    here's an example of what my command window looked like, and what message I received.


    Microsoft Windows [Version 6.0.6000]
    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Users\JaseyBoy>c:\windows\sysWOW64 regsvr vbscript.dll
    'c:\windows\sysWOW64' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Users\JaseyBoy> cd c:\windows\sysWOW64regsvr32 vbscript.dll
    The system cannot find the path specified.

    C:\Users\JaseyBoy> cd c:\windows\sysWOW64 regsvr32 vbscript.dll
    The system cannot find the path specified.





    Much appreciated as this is doing my head in.

    Monday, August 06, 2007 1:02 PM
  • Still having problems with 2738 error.  It would not let me install the new Apple software updates for Quicktime and ITunes.

    I have Vista Home Edition on a Gateway Computer.  I tried the command prompt, typed in regvsr32vbscript.dll.  It said is not recognized as an internalor external command, operable program or batch file.  What do I do now!  Help


    Friday, August 10, 2007 11:04 PM
  • Thank you so much for you post!

    I tried to install Microsoft Press Training Kit Exam Prep exam 70-536 and i got the same error. Doing this in Windows XP solved this problem aswell!

    Monday, September 24, 2007 12:59 PM
  • Try to find anything on Apple and you win.


    Tuesday, September 25, 2007 9:41 PM
  • I am very glad all you guys are so  happy but it did not work for me.
    I am running vista 64 and visual studio 2005 express.

    I get an error: Dllregister failed with error code 0x80004005!
    Any input?

    Wednesday, October 24, 2007 11:09 PM
  • Thank you Clanceyp,

       Problem thats been buging me for weeks sorted out in oh 30 seconds? Good work.


    Thursday, November 01, 2007 11:05 PM
  • i had the 2738 error some months back and couldnt iinstall safari. i tried all the fixes and they didnt appear to work. one day i tried the safari download again and it worked. i thought it was fixed until today when i tried to do a microsoft download and i got error code 2738. maybe there is no complete solution. dont bother asking microsoft as they are of less than no help.


    Friday, November 02, 2007 2:29 PM
  • Thank you, thank you, thank you.
    It has been driving me crazy for weeks.
    It finally installed.

    Maybe you would know this answer:
    I am logged on as administrator for Vista Home Premium, but it only allows me to select regular administration under my user name.
    When I try to uninstall or install some programs, it says that I do not have admin privileges.
    I do have them. Even if I right click on the program exe, and request Admin privileges, it still
    won't work.
    Any ideas? I tried several from other forums, but none of them worked. I could not even find what they said to do.  I even went in to security for user names and check off all that I could and that did not help.
    I cannot get rid of programs I no longer want. It just won't allow me to uninstalll them.

    Monday, November 05, 2007 12:46 PM
  • Thank U, Bless U!! I've been bumping into this 2738 on many occasions while on the phone with QWEST attempting to fix one problem after another. QWEST tech support had no idea what it was, let alone how to fix it. Bless U.  Works perfect.


    Wednesday, November 07, 2007 8:13 AM
  • How to enable vbscript and install itune for vista

    by new_Learner - 5/4/07 11:25 PM
    In reply to: installing iTunes by jack_201

    I just searched with google and found that below information is useful to fix this problem. Please have a try.

    When I tried to install Quicktime on Vista Home Premium, the installation wizard stalled at initiation with Error 2738.

    This is because vbscript.dll is not registered.

    I found this post on another site for registering vbscript.dll (the Apple suggested method did not work for me error 0x80004005 presumably because administrative power is not invoked first):

    Hi, found the problem. Vista for some reason dosnt register VBScript. What you have to do is first of all find where vbscript.dll is, mine was in C:\Windows\System32, but I think it changes dependant on your version. Next you need to go to start -> accessories and the right click on command prompt and click "run as administrator", next type "cd C:\Windows\System32" (replace the dir if its differnt for you) and then type "regsvr32 vbscript.dll". It should then confirm that vbscript has been registered and everything should work. This will fix a few installs, i found the same problem with itunes as well.
    Hope this helps,

    Running Quicktime install works fine after this.

    Monday, November 12, 2007 5:09 AM

    Friday, November 16, 2007 11:20 PM
  • Your amazing thanks, it was starting to drive me nuts!!!

    Saturday, November 24, 2007 11:44 PM
  • i tried that but it says dll register server in vbscript dll failed return code was 0x80004005   what should i do from here
    Sunday, November 25, 2007 6:46 PM
  • Thank you sooo much!!!!

    it really helped!!!

    Wednesday, December 12, 2007 7:06 AM
  • I'm running Windows XP and tried to load Quicktime & iTunes and i received error 2738. I could not even uninstall Quicktime without receiving this error message. I have not seen a fix for XP only Vista. Does anyone have an answer.



    Tuesday, January 08, 2008 6:58 AM
  • Thanks to dolphinthink for sorting that method out for Vista - I followed the instructions but amended them for XP and I can now uninstall QuickTime and iTunes (and update iTunes, which was my aim) following this method:


    1) Find the folder containing the file vbscript.dll - I suggest you search for this in Windows Explorer starting in directory C:\WINDOWS\.  For me, as with the original poster dolphinthink found, it was in C:\WINDOWS\System32\

    2) Open Windows Task Manager (ctrl-Alt-Delete)

    3) New Task...

    4) Just type "cmd" in the Open: dialog box

    5) Type "cd C:\WINDOWS\System32" (replace the directory if its differnent from step 1) and then type "regsvr32 vbscript.dll"
    Sunday, January 20, 2008 7:25 PM
  • you are the best....THANK YOU- THANK YOU -THANK YOU!!!!!!


    Sunday, January 27, 2008 2:43 AM
  • Clanceyp,  I have been fumbling around trying to install a Palm Pilot (oops, sorry they are now called a Handheld) for almost a week now on my laptop.  I was getting ready to send it back to the company because I couldn't install the software due to an error 2738 which their support told me was a script error.  Needless to say, everything they said to do didn't work. Your 10 second (YEA, DOS) solution did.  Thank you, thank you.  Jan R, a fast approaching geriatric nerd.


    Saturday, February 09, 2008 9:42 PM
  • you are a fucking genius! thanks man!


    Thursday, February 21, 2008 10:34 AM
  • Easiest way to resolve your problem is to turn off User Account Control. Go to Control Panel -> User Accounts and then choose to turn off after clicking on "Turn User Account on or off" link

    Sunday, March 23, 2008 1:14 AM
  • on the command prompt type:


    cd \ <enter>

    cd c:\windows\syswow64 <enter>

    regsvr32 vbscript.dll <enter>

    Sunday, March 23, 2008 1:20 AM
  • Thank you thank you.  I have not been able to update iTunes since installing Vista and was about at my wits end.  Your tip not only worked beautifully, your description of how to do it was well layed out and so easy.  Thank you for posting this, well done!  An appreciative ipod user.

    Thursday, March 27, 2008 5:49 PM
  • Cheers mate, worked for me too. Thanks for taking the time.

    Sunday, July 20, 2008 10:54 AM
  • thats perfect..thanks so much



    Sunday, August 17, 2008 10:19 AM
  •  markdauvid wrote:
    this is obviously a command pompt . can you give me the steps needed to get there.
    Did you get an answer to this?


    Saturday, August 23, 2008 8:21 PM
  • It works. I tried this once before with no success. I am not sure why it worked this time.


    Tuesday, September 09, 2008 11:55 PM
  • i keep getting a prompt saying not recognized as an internal or external command does anyone have any ideas please help me


    Saturday, September 13, 2008 7:06 AM
  • Thanks Clancyp. Spot on advice. I thought I would never get iTunes to install. Just to be able to load music on my iPod I had to find some alternative Music Management Software, WinAmp and Songbird. I like the Songbird (Mozilla) interface, simple, effective... the down side, it doesn't update the firmware on iPod.

    Perfect advice from you, got iTunes and Quicktime to install, finally.
    Thursday, September 18, 2008 9:45 PM
  • Excellent .....Thanks


    Tuesday, October 28, 2008 3:37 PM
  • dude, you are the smartest guy in the world!!! thx for you help~~~
    Monday, January 12, 2009 3:53 AM
  • Thank god for you. I have been trying to fix this problem for over a year now and have tried everything and practically every website I could find and nothing worked but these instructions. I was getting ready to wipe my hard drive completely and start from scratch to try to fix the problem. You saved me alot of time and effort. Thank you so much. It worked perfectly.
    Friday, April 17, 2009 8:09 AM
  • Hi there. I just follow ur steps and i've got this message: The module"("failed to load

    Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files.

    The specified module could not be found.

    I really need shelp guys coz its pain in the head. Cheers.

    Monday, November 01, 2010 4:27 PM
  • James , U R THE M A N !!!!!!!!!!!!!!! cheers bro. My head recking trouble came to an end.
    Monday, November 01, 2010 6:19 PM