locked
The underlying provider failed on Open. - Staging RRS feed

  • Question

  • My Webrole works fine connecting to my Azure SQL database if I am running the web role locally.
    Once I deploy it to the staging environment I get the following error.

    The underlying provider failed on Open.

    I have verified the allow Azure services is set to yes.

    What are some recommendations for debugging this?  It is driving me insane.

    Sunday, April 21, 2013 6:57 AM

Answers

  • I apologize for the delay.  I found the issue.

    I had forgotten there are two more config files for the stagging and release in the cloud.  I was only changing my web.config.

    If you run across this issue as well please look in the following spot.

    In the webRole project or Worker there is an arrow next to the web.config that expands to show two more configuration files. 

    One for staging and one for release.  I was failing to change those as well.

    • Marked as answer by Voast Dev Monday, April 22, 2013 11:39 PM
    • Edited by Voast Dev Tuesday, April 23, 2013 1:06 PM post a more detailed answer.
    Monday, April 22, 2013 11:39 PM

All replies

  • Can you share more details like maybe...sample connectionstring or technology to connect with SQL here...with limited details it is difficult to suggest something...in the meantime see link here..if that helps

    http://stackoverflow.com/questions/2475008/the-underlying-provider-failed-on-open

    Sunday, April 21, 2013 12:55 PM
  • I agree with Saransh, 

    we need more details about your solution and if possible a small sample app that can reproduce the issue in isolation,

    in lack of the details my first guess is that your local config have settings to connect to your sql db, but your cloud config may not have correct connection information about your sql azure db..

    regards,

    Vishal


    Vishal Narayan Saxena http://twitter.com/vishalsaxena

    Monday, April 22, 2013 11:00 PM
  • I apologize for the delay.  I found the issue.

    I had forgotten there are two more config files for the stagging and release in the cloud.  I was only changing my web.config.

    If you run across this issue as well please look in the following spot.

    In the webRole project or Worker there is an arrow next to the web.config that expands to show two more configuration files. 

    One for staging and one for release.  I was failing to change those as well.

    • Marked as answer by Voast Dev Monday, April 22, 2013 11:39 PM
    • Edited by Voast Dev Tuesday, April 23, 2013 1:06 PM post a more detailed answer.
    Monday, April 22, 2013 11:39 PM
  • Hi Voast Dev,

    I appreciate you posting back with what you find but this is not the forum etiquette, I helped you figure it out and instead of marking my post as answer you marked your own post as answer, do you realize people spend time out of there busy schedule to help community.

    If my post helped you, please mark it as answer i will highly appreciate.

    regards,

    Vishal


    Vishal Narayan Saxena http://twitter.com/vishalsaxena

    Tuesday, April 23, 2013 5:20 AM
  • I truly appreciate the attempt and willingness to help by both parties that responded.  I really do.  That being said I answered my own question before I ever read your request for more data.  I came back here to remove the post however it had responses so I was unable to.  The answer to the problem was to check the other configuration files. Which is what I said in my post.  So if someone runs across this same issue and finds this posting that they would know which post contains the solution.  That is point of the forums is it not?  You post although helpful in nature did not help me and it does not contain the answer to the problem and that is why it is not marked as the answer.  I am sorry if this offends or upsets you, that was not my intention.
    Tuesday, April 23, 2013 1:02 PM