none
VS 2015 crashes on startup

    Question

  • When I started Visual Studio 2015 this morning it crashes right away with the following message:

    "Exception has been thrown by the target of an invocation."

    Searching I found mention of the "PATH" environment variable being too long but that is not my case. 

    Need some urgent help here and I hope someone has a clue as to what is going on,

    Sid

    Friday, December 11, 2015 5:59 PM

All replies

  • Could someone please help with this, my development is on hold until I can resolve this issue.

    Sid

    Monday, December 14, 2015 9:14 PM
  • Hi Sid,

    Do you get any updates before this error occurs?

    Please try to repair your Visual Studio through Control Panel -> Programs -> Visual Studio 2015 -> Change -> Repair.

    If still doesn't work, please try with following steps to troubleshoot this problem.

    1. Run Visual Studio as administrator.
    2. Run Visual Studio 2015 Community in safe mode with "Deven.exe /SafeMode" command to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    3. Close all third part software, such as antivirus.
    4. Please check the ActiveLog.xml under the path of %AppData%\Microsoft\VisualStudio\14.0. This file will log all operations when you operate Visual Studio.

    If above steps don't work and there doesn't have any error message in ActiveLog file, please run “SFC /scannow” to repair the embed .NET first, refer to:  https://support.microsoft.com/en-us/kb/929833

    Then use .NET Framework Setup Verification Tool to verify the .NET Frameworks on your machine, you can download from here: http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    By using it, you will find the log file under %TEMP% folder, see the first 15 lines and the last 15 lines.

    If the exit code != 0, it means that your .NET installed incorrectly, please first use .NET Framework Repair Tool to repair it, http://www.microsoft.com/en-us/download/details.aspx?id=30135

    Best Regards,
    Weiwei


    Tuesday, December 15, 2015 6:16 AM
    Moderator
  • Hello Weiwei and thank you for your reply. I tried all you suggested and indeed there were file errors reported by "sfc" however, despite all efforts on my part I was unable to fix the problems by using the instructions given on various MS help sites.

    Therefore, since work needed to proceed I rebuilt the VM hosting VS 2015 and abandoned all hope of fixing my original VM.

    This thread should be considered as resolved by other means and closed,

    Sid

    Monday, December 21, 2015 3:31 PM
  • Hi Sid,

    Thanks for your response.

    Since you have rebuilt a new VM to hosting VS2015 and abandoned the original VM, I will close this thread later.

    If any question about Visual Studio IDE in future, please feel free to come back to our forum.

    Best Regards,
    Weiwei

    Tuesday, December 22, 2015 2:33 AM
    Moderator