locked
Azure Stack Portal - Failed to load the marketplace RRS feed

  • Question

  • After countless reruns and redeployments I've finally completed the deployment successfully.

    Unfortunately, when I access the Azure Stack portal from the MAS-CON01 machine I cannot view the marketplace. After clicking on the "New" button, the marketplace pane / blade fails to load any categories and presents the error title "Failed to load the marketplace" with the description "Could not load the marketplace data". 

    The Azure AD account I'm using is a trial account with an active trial subscription to Azure if this has any impact. 

    I've tried rebooting all of the deployed VMs several times. Any ideas?

    Wednesday, January 25, 2017 12:37 AM

Answers

  • OK I've resolved this issue.

    I remembered thinking the deployment completed very quickly after step "60.140.146 (FBI) Configure Windows Defender". No errors that I recall but it went through the last few steps very quickly and ended up on the "COMPLETE: Action 'Deployment'". 

    On a hunch I went and issued a command to restart the deployment from the next step 60.140.161 since the -rerun no longer works after a successful install.

    invoke-eceaction -RolePath Cloud -ActionType Deployment -start 60.160.161

    It seemed to take much longer to process the rest of the steps than on my previous run through and completed successfully. Upon loading the Azure Stack portal I noticed that the Resource Providers section now has Storage, Network, Health and Compute whereas previously this only listed Storage. 

    I can now load the marketplace successfully.

    • Marked as answer by bobrbobrbobr Wednesday, January 25, 2017 6:19 AM
    Wednesday, January 25, 2017 5:56 AM

All replies

  • Hi,

    What Account are you accessing the Azure Stack portal with?

    NOTE: Only the Service Administrator (the AADGlobalAdmin.onmicrosoft.com used to deploy Azure Stack) can access the Market Place unless you have created a Plan + Offer and added a +Tenant Subscription.

    Thanks


    Gary Gallanes

    Wednesday, January 25, 2017 3:40 AM
  • Thanks Gary,

    I am signing in using the "myuser@mydomain.onmicrosoft.com" which was specified during the Azure Stack deployment - I guess this means it's the service administrator?. This is simply a trial Azure AD account which I created prior to the Azure Stack deployment. I assume there are no permissions I need to set on this account from the Azure AD side of things? 

    Wednesday, January 25, 2017 4:06 AM
  • OK I've resolved this issue.

    I remembered thinking the deployment completed very quickly after step "60.140.146 (FBI) Configure Windows Defender". No errors that I recall but it went through the last few steps very quickly and ended up on the "COMPLETE: Action 'Deployment'". 

    On a hunch I went and issued a command to restart the deployment from the next step 60.140.161 since the -rerun no longer works after a successful install.

    invoke-eceaction -RolePath Cloud -ActionType Deployment -start 60.160.161

    It seemed to take much longer to process the rest of the steps than on my previous run through and completed successfully. Upon loading the Azure Stack portal I noticed that the Resource Providers section now has Storage, Network, Health and Compute whereas previously this only listed Storage. 

    I can now load the marketplace successfully.

    • Marked as answer by bobrbobrbobr Wednesday, January 25, 2017 6:19 AM
    Wednesday, January 25, 2017 5:56 AM
  • Great feedback Bobr! Glad it worked out for you.

    Cheers,

    Ruud
    Twitter:    Blog: AzureStack.Blog  LinkedIn:    
    Note: Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    Wednesday, January 25, 2017 8:46 AM
  • Azure Stack TP3 has been released on March 1, 2017.

    If you are experiencing any issues with the TP2 release, please download and redeploy using the latest Azure Stack POC deployment package

    Please see the updated deployment documentation:

    https://docs.microsoft.com/en-us/azure/azure-stack/azure-stack-run-powershell-script

    And updated Azure Stack Docs:

    https://docs.microsoft.com/en-us/azure/azure-stack/

    If you experience any issues with TP3 release, feel free to contact us.

    https://azure.microsoft.com/en-us/blog/hybrid-application-innovation-with-azure-and-azure-stack/

    Wednesday, March 1, 2017 7:12 PM