locked
BinScope 2014 not accepting target path in command line. RRS feed

  • Question

  • I entered the following in an administrator command prompt:

    C:\Program Files\Microsoft BinScope 2014>binscope.exe /target "\Release"
    Microsoft BinScope 2014
    BinScope: The path "\Release" did not exist or was a directory. BinScope accepts only paths to existing files.

    BinScope is newly installed.  The folder does exist on the C: drive and there are multiple exe files in the folder.  I first tried this specifying a folder on my D: drive but got the same error.  I also tried "/target "C:\Release" and got the same error.  This is on a Windows 7 64-bit desktop.

    I was using the previous version of BinScope (1.2 I think) and had no problems using the GUI to scan my binaries.  This is my first attempt at using the new BinScope 2014 version.


    • Edited by rghines51 Saturday, March 14, 2015 12:06 AM
    Friday, March 13, 2015 11:39 PM

All replies

  • rghines51, did you get an answer to your question? I am having the same issue with directories. I can add a path\filename which works, but /Target C:\myfiles with or without quotes pops the same error you get.

    I must say the docs for this tool are awful. No wonder we toss the manual over our shoulders when we get a new program.  /Target <string> is supposed to test all the files in the directory, or "Item(s) to scan (multiple)" per the manual.

    For now I just run Binscope through AutoIt and pass each file in a loop to test them all.

    JibsMan

    Wednesday, May 20, 2015 5:14 PM
  • The 2014 version of BinScope does not support directory scanning.

    https://blogs.microsoft.com/microsoftsecure/2014/11/20/new-binscope-released/

    Other changes in BinScope 2014 include:

    • Removal of directory scanning, instead individual binary paths should be provided
    Thursday, January 19, 2017 4:21 PM