locked
Update SDWebImage for iOS RRS feed

All replies

  • User28276 posted

    What is the problem with SDWebImage and iOS 8? I have not detected any problem yet.

    Wednesday, October 15, 2014 5:50 PM
  • User74374 posted

    .SetImage is not working for me? Create a new project and add SDWebImage and see if it's works or not?

    Friday, October 17, 2014 12:41 AM
  • User28276 posted

    In my case I don't upgrade the component since 3.5.4 That version works fine for me under iOS8 (SetImage with completedHandler callback,...).

    Friday, October 17, 2014 8:53 AM
  • User74374 posted

    How do I go back to old version? Any ideas?

    Friday, October 17, 2014 11:19 PM
  • User28276 posted

    https://components.xamarin.com/download/sdwebimage/sdwebimage-3.5.4

    Saturday, October 18, 2014 11:35 AM
  • User25708 posted

    3.5.4

    Works fine .

    updated to 3.7 gives me this error

    Type MonoTouch.UIKit.UIImageView' does not contain a memberSetImage' and the best extension method overload `SDWebImage.WebCacheUIButtonExtension.SetImage(this MonoTouch.UIKit.UIButton, MonoTouch.Foundation.NSUrl, MonoTouch.UIKit.UIControlState, MonoTouch.UIKit.UIImage, SDWebImage.SDWebImageOptions, SDWebImage.SDWebImageCompletionHandler)' has some invalid arguments (CS1928)

    Saturday, November 8, 2014 2:44 PM
  • User25708 posted

    Found problem . Documentation is old and still shows old way of calling SetImage. This should be update to ...

    ImageView.SetImage( new NSUrl ("http://example.jpg"), null, SDWebImageOptions.ProgressiveDownload, null, null );

    this works for me now .

    Saturday, November 8, 2014 3:26 PM
  • User83443 posted

    Up. Issue (placeholder not replaced by dowloaded image) on iOS 9 with https url ... :sweat:

    Check http://stackoverflow.com/questions/30739473/nsurlsession-nsurlconnection-http-load-failed-on-ios-9 ;)

    Wednesday, September 30, 2015 12:38 PM