locked
Crystal Report components disappear from object browser after re-build the solution. RRS feed

  • Question

  • Hi All,


    I got this trouble for few days. And it's stop my progress. There have no defaulted crystal report components in VS 2010. So I installed SAP Crystal Report Version for VS2010 on my Visual Studio IDE. Looks nothing wrong until I build the project.

    The components were included in the project automatically, by creating a new report file.  And they can be found in Object Browser. Everything looks fine. The classis can be viewed in Object Browser. But after build the solution, they all disappear! And error message been reported. (Error    4    The type or namespace name 'CrystalDecisions' could not be found (are you missing a using directive or an assembly reference?))

    It's looks like some internal problem of the IDE. The Visual Studio 2010 SP1 has already been installed and the SAP Crystal Report Version for VS2010 (it should be the last version which i just download from their offical web site days ago) also been reinstalled couple of times. I'm pretty sure that what installed was 32bit version which is I need. I have no experience about this before. And all online help just tell me reinstall and again.

    Is anybody get any idea? Thanks!!!


    I Believe, I Can
    Sunday, July 10, 2011 11:41 PM

Answers

  • Hi xuts,

    Set your Projects Framework to Full and not client. Also, search and SAP Crystal Reports .NET forum for more info and configurations settings and known issues:

    http://forums.sdn.sap.com/forumfilter.jspa?forumID=313

    Don


    Don Williams
    • Proposed as answer by SAPDon Monday, July 11, 2011 2:14 PM
    • Marked as answer by xuts Saturday, July 16, 2011 12:03 PM
    Sunday, July 10, 2011 11:57 PM

All replies

  • Hi xuts,

    Set your Projects Framework to Full and not client. Also, search and SAP Crystal Reports .NET forum for more info and configurations settings and known issues:

    http://forums.sdn.sap.com/forumfilter.jspa?forumID=313

    Don


    Don Williams
    • Proposed as answer by SAPDon Monday, July 11, 2011 2:14 PM
    • Marked as answer by xuts Saturday, July 16, 2011 12:03 PM
    Sunday, July 10, 2011 11:57 PM
  • Thanks man!
    I Believe, I Can
    Monday, July 11, 2011 1:29 AM
  • too good!!!

     

    this work:

    Set your Projects Framework to Full and not client.


    I Believe, I Can
    Monday, July 11, 2011 1:32 AM