Biztalk 2009 : Cannot connect to SAP Server ECC 6.0 RRS feed

  • Question

  • Hi All,

    I have query regarding connecting to SAP ECC 6.0 using BizTalk Adapter V2.0 for MySAP Business Suite..
    when i do Add generated Items --> then give following details

    Credentials username & password

    1)      Application Server Host Name   

    3)      Gateway Service (System ID) 

    4)      System Number  

    5)      Client 



    and tries to connect it, but it directly closes the visual studio application and come out without throwing any error.

    I have checked the event viewer also, but can't found any error.


    I tried connecting through Add Service Reference and pass the uri, but same above thing is happening.


    Is anything missing as parameter which needs to be pass to SAP.


    any other way to connect to SAP system ( any sample available )


    Thursday, May 12, 2011 11:14 AM


  • What is the version of your Operatinog System ?

    This is a known issue with Vista and above operating systems.

    This is because SAP .Net connector (the underlying client library used by the old SAP adapter) has an access violation.

    This issue is not caught by XP/Server 2k3 and prior opearting systems and so the add generated items works fine.

    Vista introduced more stringent checks for Acces Violation, so this AV is caught by the OS and it terminates the process.

    The support for SAP .Net connector has ended the last OS on which SAP.Net connector is supported is XP/Server 2k3 .

    So, the option for you (if using Vista and above OS ) is either to use XP/Server2k3 or

    use the WCF-SAP adapter(recommended).



    Rohit Singh
    Thursday, May 12, 2011 5:58 PM
  • Also, I think BizTalk Adapter V2.0 for MySAP Business Suite is not suppoted with SAP ECC 6.0. It is depricated in Biztalk 2009 and not supprted with biztalk 2010.  For any new development the WCF-SAP adapter from Biztalk adapter pack is recommended.  For migration , Biztalk adapter migration tool can help.

    Rohit Singh
    Thursday, May 12, 2011 6:10 PM

All replies