none
Framework 3.5 deployment warning RRS feed

  • Question

  • I have built a Deployment application for my program that uses .Net framework 3.5.  After a build I get the following warning Item '.NET Framework 3.5' already includes '.NET Framework 2.0 (x86)' as I have both checked off in my prerequisits.  If I uncheck 2.0, the build just fails, with no disernable error message.

     

    Should I just ignore this message and leave both framework options checked or am I missing something?

     

    BTW, this is an updated VS2k5 project to VS2k8, the reference to 3.5 was changed in advanced compile options when I needed to add Linq support.

     

    Thanks in advance.

    Jim

    Tuesday, May 6, 2008 8:12 PM

Answers

  • Hi Jim

     

    .NET 3.5 sits on top off .NET 3.0 which in itself in built on top of .NET 2.0 Framework bits. I am guessing that your deployment application has certain dependancies on 2.0 bits which causes this build failure when you uncheck 2.0.

     

    You can target a specific Framework version using the instructions listed out in http://msdn.microsoft.com/en-us/library/9w519wzk.aspx. AFAIK leaving both the Framework options checked shouldn't cause any trouble.

     

    Thanks
    Thursday, May 8, 2008 2:11 AM
    Moderator

All replies

  • Hi Jim

     

    .NET 3.5 sits on top off .NET 3.0 which in itself in built on top of .NET 2.0 Framework bits. I am guessing that your deployment application has certain dependancies on 2.0 bits which causes this build failure when you uncheck 2.0.

     

    You can target a specific Framework version using the instructions listed out in http://msdn.microsoft.com/en-us/library/9w519wzk.aspx. AFAIK leaving both the Framework options checked shouldn't cause any trouble.

     

    Thanks
    Thursday, May 8, 2008 2:11 AM
    Moderator
  • I had this problem with a setup project because I had both Prerequisites ".NET Framework 2.0 (x86)" and ".NET Framework 3.5 SP1" checked. I removed the check for .NET 3.5 SP1 and the warning went away.
    Tuesday, August 17, 2010 12:27 PM