locked
PWA 2010 Project Center View - Formula error RRS feed

  • Question

  • The following formula was used in a project center view in Project PWA 2003:

    IIf([Baseline Finish]=ProjDateValue('NA'),"No Baseline",IIf(ProjDateDiff([Baseline Finish],[Finish])/480>10,"Late > 10 days",IIf(ProjDateDiff([Baseline Finish],[Finish])/480>0,"late",IIf(ProjDateDiff([Baseline Finish],[Finish])/480<0,"Ahead of schedule","On schedule"))))

    However, the same formula is not working in PWA 2010.  I tested it by opening a project in Project Pro and added this in as a "Task" text custom field and it works fine.  There does not appear to be a way to test a "Project" custom field there, however.  In Project Pro, I added this in as a custom "Project" field.  When looking at this in a project now, it shows "#Error" and nothing shows in the Project Center View I added it to.  There does not appear to be a way to add a "Task" field to a project center view.  I looked at a few blogs, but there I'm told to make it an Enterprise Project Text custom field, but I don't see that option in my fields list, so I'm currently stumped.

    Monday, October 4, 2010 4:15 PM

Answers

  • Hi Naomi,

    if a project was published before defining a formula like that, you need to restart Project Professional (what you did) AND hit F9 for recalculation before publishing. This should remove your "#Error". 

    Regards
    Barbara

    Tuesday, October 5, 2010 5:36 AM
  • I think you may have used a local custom field instead of an enterprise custom field....?

    1) Create an Enterprise Custom Field at the Task level (Server Settings > Enterprise Custom Fields).  Paste the formula, set to rollup by using the formula.  Let's call this field "Schedule Status Task."

    2) Create an Enterprise Custom Project Field at the Project level (same interface).  Set the formula as "=[Schedule Status Task]"  Let's call this "Schedule Status Project."

    3) Add the Schedule Status Project to a Project Summary View

    Works just fine....


    Andrew Lavinsky [MVP] Twitter: @alavinsky Blog: http://blogs.catapultsystems.com/epm
    Monday, October 4, 2010 8:00 PM

All replies

  • Try the following:

    1) Copy that formula into a custom Task level field.  Set it to use the formula for summary rows.  Save and Publish the schedule.

    2) Create a new Project field.  Set the Project field to equal the custom field you created at the task level.  This field should now surface the Project Summary level task data.

    I haven't tried this in PWA 2010, but my guess is that one or more of the fields referenced doesn't have a Project level counterpart.


    Andrew Lavinsky [MVP] Twitter: @alavinsky Blog: http://blogs.catapultsystems.com/epm
    Monday, October 4, 2010 4:29 PM
  • Andrew,

    I had previously done Step 1 above (and it calculated fine for the summary task) and then tried to do Step 2, but cannot find a way to do it.  When you create a new a new custom field in PWA, you do not have an option to match it to another field.  If you try to create a new field in Project Pro by adding a column, no "Project" level generic options (such as an "Enterprise Project Text" field) are available.


    Naomi Flanagan
    Monday, October 4, 2010 7:13 PM
  • I think you may have used a local custom field instead of an enterprise custom field....?

    1) Create an Enterprise Custom Field at the Task level (Server Settings > Enterprise Custom Fields).  Paste the formula, set to rollup by using the formula.  Let's call this field "Schedule Status Task."

    2) Create an Enterprise Custom Project Field at the Project level (same interface).  Set the formula as "=[Schedule Status Task]"  Let's call this "Schedule Status Project."

    3) Add the Schedule Status Project to a Project Summary View

    Works just fine....


    Andrew Lavinsky [MVP] Twitter: @alavinsky Blog: http://blogs.catapultsystems.com/epm
    Monday, October 4, 2010 8:00 PM
  • Andrew,

    I did not know I could set the formula in the project field to equal that other field (using the brackets).  I bet it works, too.  I'll try it and let you know.

     

    Naomi


    Naomi Flanagan
    Monday, October 4, 2010 8:10 PM
  • Andrew,

    Not sure what is going on.  Someone just put in a new project and, for that one project, the custom status field in the view is working the way I originally set it up (I had not yet tried your suggestion).  I thought maybe it was because that project had just been published, so I went back and published mine but there was no change.  I also tried restarting Project Pro.  The project that worked is showing the "No Baseline", which should also be the case for one of the projects that I just published again.  I looked at both my projects in Project Pro and putting in the custom status column it shows "#Error".  I went through and put in the entire formula a piece at a time (by cut and paste) once more into a different custom task text column to make sure there was no problem within the statement, but it worked all the way through with all tasks and rolling up. 

    Any ideas?

    Naomi

     


    Naomi Flanagan
    Monday, October 4, 2010 10:24 PM
  • Hi Naomi,

    if a project was published before defining a formula like that, you need to restart Project Professional (what you did) AND hit F9 for recalculation before publishing. This should remove your "#Error". 

    Regards
    Barbara

    Tuesday, October 5, 2010 5:36 AM
  • I thought I responded to this before, but it appears to have "disappeared".  The F9 worked, but now I have a similar problem with the graphical indicators I updated on the custom field.  The previous text (such as "On schedule") has disappeared.  Restarting Project Server, opening the project, hitting F9, Publishing and then closing the project don't make a difference.  However, once again and new project just added shows the indicator. 

    Naomi

     


    Naomi Flanagan
    Tuesday, October 5, 2010 3:47 PM
  • I did notice that manual tasks cause that Error message to show up with the formula.  I might take a look at that formula and see if it's giving you an Error condition.
    Andrew Lavinsky [MVP] Twitter: @alavinsky Blog: http://blogs.catapultsystems.com/epm
    Tuesday, October 5, 2010 4:40 PM
  • Andrew - The formula for the custom field was working fine in my Project Center View (after using F9 and then Publishing).  It is when I updated the custom field to show the graphical indicators (instead of a text phrase) that my latest problem occurs.  Nothing shows up in the custom field when used in a Project Center View.  If I look at the custom field in a project (by adding the appropriate column) the graphical values show up.

    Update (10/6/10) I ended up deleting the fields and views and re-entering them, putting in the graphical indicators from the very beginning.  Then I had those with already published projects open them, use F9 to update the formulas, and re-publish the projects.  Everything is now working as expected.  Thanks to everyone for their help, especially Barbara who provided what turned out to be the critical piece of information.

    Naomi


    Naomi Flanagan
    Tuesday, October 5, 2010 8:14 PM
  • Andrew, I think I am close, but still no joy. I created the task level field (called "Stoplight"). Then I attempted to create the project level counterpart, with a formula "=[stoplight]"

    I set simple formulas for graphical indicators just to test 1=green dot, 2=yellow dot, 3=red dot

    When I attempt to save it, I get

     

    "The custom field could not be saved due to the following reason(s):

    • This formula contains errors. Correct the formula and try again."

     

     

    I removed all the graphical display definitions just to make sure that was not the issue. Still same error.

    Then I changed it to a formula of just

    "=4"

    and still same error.

     

    I think there must be something else at work - security setting or something - and the formula was ok all along. Thoughts?

    Thanks!

    Don Cooley, Peritius Consulting

    Sunday, February 13, 2011 5:47 PM
  • dbciii --

    The formula should be simply [stoplight] and not =[stoplight].  Hope this helps.


    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    • Proposed as answer by dbciii Tuesday, March 29, 2011 4:53 PM
    Sunday, February 13, 2011 9:44 PM
  • Thanks!

    I got it to accept a formula - just copied and pasted one that works in Project2010 and removed the "=". It just sets values of 3,2, or 1 based on comparison of finish to baseline finish.

          IIf([Baseline Finish] - [Finish] < -10, 3, IIf([Baseline Finish] - [Finish] < 0, 2, 1))

    Works like a charm in project2010. Graphics settings: 3=red, 2=yellow, 1=green

    When I include the new task-level enterprise field in a view in PWA, it is blank. I took off the graphics indicators to see if it was doing the calc, and it is still blank.

    I went on to follow the guidance above and added a project-level enterprise field that equates to the task level one, added it to a summary view. It is  blank too.

    When I add the enterprise columns to the ProjectPro view, they are properly populated with 1,2,3, matching the original local field.

    When I put the graphic display option back on the PWA field, they display as graphics in ProjectPro.

    So it works, to the extent that I have enterprise fields to utilize rather than having to re-create the custom fields for every project.

    But I so far can't get a "stoplight" view in PWA , which I want to use heavily for executive-level briefings.

     

    Then I noticed this comment on the custom field edit page:

    "Graphical indicators are not displayed in all areas of Project Web App."

    Is there someplace where this is explained in detail?

     

     

     

     

     

    Monday, February 14, 2011 10:06 PM
  • Did you publish the project after getting the indicators to work in Project?
    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG
    Monday, February 14, 2011 10:12 PM
  • dbciii --

    If you create a custom field containing a formula AFTER you already have enterprise projects in the system, your PMs have to open each of their projects, press the F9 function key to recalculate the project, and then publish the project.  After doing this, the custom field should show the desired result in PWA.  Hope this helps.


    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    Monday, February 14, 2011 10:16 PM