locked
.Net remoting CallContext not working in Integrated Mode. RRS feed

  • Question

  • Hi,

    I am using .net remoting GetData and SetData method from the CallContext class. The issue here is, this only works when i set the app pool to classic mode. When i set it to integrated mode the context returns no data. I need to move my application to integrated mode as few other featured are not working as expected in Classic mode.
    Any guidance here would be helpful.

    Thanks in advance!

    Tuesday, May 15, 2018 4:02 PM

Answers

  • Thanks Wendy,

    I was able to resolve my issue using the appcmd.exe migrate config command. You initial linked helped me search in the right direction.
    Another useful link :- https://keylimetie.com/blog/2008/11/14/migrating-aspnet-applications-to-iis-70-integrated-mode/

    Thanks,
    Prasad

    Wednesday, May 16, 2018 1:35 PM

All replies

  • Hi Prasad Parameswaran,

    Thank you for posting here.

    For your question, what is the type of your project? If your application is ASP.NET app, and you want to make your application work in Integrated Mode, you could try to migrate a Web.config File for Use in Integrated Mode. Please try the steps in MSDN document.

    https://msdn.microsoft.com/en-us/library/bb515251.aspx?f=255&MSPPError=-2147217396

    Best Regards,

    Wendy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, May 16, 2018 2:05 AM
  • Hi Wendy,

    Thanks for your reply. We are actually using this in a DNN project in one of our modules.

    We had to move to integrated mode as a part of our upgrade. But one of the features where we use .net remoting for CallContext to get and set data is not working.Thanks,

    Prasad

    Wednesday, May 16, 2018 7:34 AM
  • Hi Prasad Parameswaran,

    Our forum does not support this open source. Please post a new thread in StackOverFlow.

    https://stackoverflow.com/questions/tagged/dotnetnuke

    The CLR Forum discuss and ask questions about .NET Framework Base Classes (BCL) such as Collections, I/O, Regigistry, Globalization, Reflection. Also discuss all the other Microsoft libraries that are built on or extend the .NET Framework, including Managed Extensibility Framework (MEF), Charting Controls, CardSpace, Windows Identity Foundation (WIF), Point of Sale (POS), Transactions.

    Best Regards,

    Wendy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, May 16, 2018 8:14 AM
  • Thanks Wendy,

    I was able to resolve my issue using the appcmd.exe migrate config command. You initial linked helped me search in the right direction.
    Another useful link :- https://keylimetie.com/blog/2008/11/14/migrating-aspnet-applications-to-iis-70-integrated-mode/

    Thanks,
    Prasad

    Wednesday, May 16, 2018 1:35 PM