locked
"The method or operation is not implemented" when trying to run unit test from visual studio 2010. RRS feed

  • Question

  • Quite frequently when selecting the option "Run Tests in current context" when in a recently written test-method of a test class a message box appears saying "The method or operation is not implemented".

    I am running Visual Studio 2010 SP1.

    Sometimes it helps just forcing a rebuild of the test project by adding a new empty line in the file being affected, but then after making a change in a referenced assembly the same error appears again. Some times it seems the only solution is to restart the studio.

    Does anyone have any idea on what may be causing this and what to do about it? It really hinders productivity quite a lot when writing unit tests for us.

    Monday, May 30, 2011 8:22 AM

Answers

  • The problem seems to be when having C++ projects loaded in the solution. Once I unload all the C++ projects these strange errors disappear.
    • Marked as answer by Peter Palotas Wednesday, April 3, 2013 4:14 PM
    Tuesday, February 14, 2012 7:21 PM

All replies

  • Hi,

    Do you see the same issue when running tests from test list editor.

    I would recommend using the Test List editor since that way you always point to the right method. Run Tests in current context can often lead to mistakes.

    Thanks,

    Anuj


    Wednesday, June 1, 2011 2:11 AM
  • Yes, the same problem appears when running from the test list editor in these cases.
    Wednesday, June 1, 2011 9:40 AM
  • The problem seems to be when having C++ projects loaded in the solution. Once I unload all the C++ projects these strange errors disappear.
    • Marked as answer by Peter Palotas Wednesday, April 3, 2013 4:14 PM
    Tuesday, February 14, 2012 7:21 PM