none
Download failure: "The controller for path '/undefined'" RRS feed

  • Question

  • At https://my.visualstudio.com/downloads, when attempting to download "SQL Server 2012 Developer Editor with Service Pack 4", x64 German DVD, I get a page consisting solely of the text message:

    The controller for path '/undefined' was not found or does not implement IController.

    The same happens with x64 Simplified Chinese DVD. I've not attempted any more downloads since this error appeared. Downloads were working this time yesterday.

    I find the error happens under both Firefox 56.0.2 on fully patched macOS Sierra, and Edge (sorry, I've no clue how to display version information in Edge) in Windows 10 15063.674.

    Enjoy!

    Tuesday, October 31, 2017 3:22 AM

All replies

  • Hi,

    You can try "revert to old downloads experience"

    Tuesday, October 31, 2017 3:41 AM
  • That gives me a sad face and "Something went wrong!"

    The page is https://my.visualstudio.com/Errors?e=46

    with Message code: 715-123150.

    Interestingly, it also assures me my subscription is invalid. Mmmm ... I'm using a VPN to connect; perhaps that's caused headaches (it's plausible that MSDN security code may flag my (valid) login as dubious). I'll test that now.

    Tuesday, October 31, 2017 5:09 AM
  • Aha: it was the VPN. I reconnected away from Gallifrey and things started to behave. Trantor is good.

    Tuesday, October 31, 2017 5:28 AM
  • Currently I have the same issue.

    I receive the "controller for path /undefined" if I try it with Firefox. Then I receive the screen "Something went wrong" with "with Message code: 715-123150".

    With IE I receive the forever downloading. It is not possible to download the sql server 2012 sp4. With IE and old download experience there are not downloads for sql 2012 sp12. There are showed, but they have Release Date N/A and no download links.

    Currently I would like to have the earliest download experience of msdn. The current download experience old and new do not work.

    Tuesday, October 31, 2017 12:26 PM
  • Yes, I'm having issues downloading SQL 2012 with SP4 too.

    It seems that the SQL Server 2012 Express with Service Pack 4 release has two different entries, one with a release date of Feb 2017 that I see most frequently and another with a release date of Oct 2017.

    When I see the Feb 2017 release, then I can't see the rest of the SP4 items correctly (old download experience shows Release date N/A) but when I see the Express entry with a release date of Oct 2017, then I can see the rest of the SQL 2012 SP4 releases with a release date of Oct 2017 but, upon downloading, I get the same error about being unable to validate my subscription etc.

    I emailed support about this, but have had zero response after 24 hours.

    Wednesday, November 1, 2017 6:03 AM
  • Same here, can't download anything anymore from https://my.visualstudio.com/downloads

    I'm immediately greeted with an 715-123150 error.

    This happens with Firefox, Chrome and Edge :-(

    Any news from anybody?

    Wednesday, November 1, 2017 7:59 AM
  • Same for me, and I have like 5 MSDN subscriptions connected to my account. NotHappy

    Rok Bermež

    Wednesday, November 1, 2017 3:00 PM
  • I'm experiencing the same problem right now trying to download Windows 10 1703 :(
    Wednesday, November 1, 2017 6:55 PM
  • Here's a potential temporary solution for some until Microsoft resolve the problem.

    I use a VPN service (Private Internet Access). I find when I connect via some locations, such as Amsterdam, I get the error. When I connect via others, such as Berlin, downloads work.

    This seems to be a problem with the distribution of the MSDN/Visual Studio download website.


    • Edited by Devon Garde Thursday, November 2, 2017 5:51 AM
    Thursday, November 2, 2017 5:51 AM
  • Thank you for this information. 

    Unfortunately I get the same error and I´m not able to use a VPN or another location connection. 
    I hope Microsoft will find a fix for this soon. 

    Thursday, November 2, 2017 7:00 AM
  • Same here. Working from home and urgently need a download... :-(
    Saturday, November 4, 2017 6:38 PM
  • Another workaround that sometimes works for me is this:

    Log out. Close the browser. Restart the browser. Log in. Retry the download.

    The problem might be borked identity challenge code.

    Sunday, November 5, 2017 3:04 PM
  • I had the exact same problem on my new laptop. I can use chrome on my old laptop to download but not on my brand new laptop. Which made me suspect it was a browser settings issue. And it is. So I switched to  Internet Explorer on my new laptop and the downloads worked. I have not been able to pinpoint yet what the browser setting is which causes this. probably some security setting
    Thursday, November 9, 2017 8:20 PM
  • I am running into this problem.  Logging out, shutting down the browser and retrying doesn't help.  I do not have a VPN (so it's not the cause of the problem or a potential solution).

    MSDN is becoming more and more of a frustration over time.

    Sunday, November 19, 2017 6:31 AM
  • Not using a VPN but getting the same issues: All I can download is frustration and a waste of time.  I wish I could get someone to pay me $2600/yr for nothing but a hard time.

    AJ§

    Monday, November 20, 2017 4:59 AM
  • Found a solution:  Give up on MS IE, MS Edge, Opera, Chrome and use FireFox.  Should have known Microsoft products wouldn't work with Microsoft products.

    AJ§

    Monday, November 20, 2017 5:13 AM
  • They are limiting downloads and not telling people.  If you download too many items in a row it flags your account as suspicious. So they are blocking people and using an erroneous error and you have to wait for the system to reset its self.  Its nice that you paid for the privilege of being blocked for downloading to many items at once.
    Monday, April 20, 2020 9:39 PM