none
Using reference data and JSON shape with leading zero RRS feed

  • Question

  • Dear all,

    we are currently investigating into TSI and came accross the reference data. 

    Our JSON Shape is as follows: 

    {
    	"Timestamp": "2019-05-12T14:33:40.3027145Z",
    	"TimestampDAP": "2019-06-12T14:33:40.3027182Z",
    	"asset": {
    		"serialnumber": 5000613
    	},
    	"telemetry": [
    		{
    			"ucn": "00001929",
    			"value": 26
    		},
    		{
    			"ucn": "00002212",
    			"value": 6.00
    		},
    		{
    			"ucn": "00007939",
    			"value": 45.5731
    		},
    		{
    			"ucn": "00007940",
    			"value": -41.1112
    		}
    	]
    }

    The reference data contains two columns "telemetry.ucn"  and "ucn.displayname" having a row "00007490" | "GPS_latitute".

    On processing now the matching with leading zero in JSON and reference data does not work.

    Removing the leading zero in both it does. However engineers working with TSI would like to see the leading zeros.

    Is this a bug in TSI implementation?

    Thanks for help

    Bruno

    Wednesday, June 12, 2019 2:58 PM

All replies

  • Hello Bruno,

    Can you give more details on the error you see when using "00007490" instead of "7490" ? Do you notice the same when using similar values on a JSON Object '{ }' instead of JSON Array '[ with nested JSON Object { } ]' ?

    Another clarification needed: Are you using TSI GA or TSI Preview?

    Thanks!


    Wednesday, June 19, 2019 9:45 AM
    Moderator
  • Hello Bruno,

    Let us know if you are still blocked? If still blocked, can you share the information asked above?

    Thank you!

    Monday, July 8, 2019 10:06 AM
    Moderator