locked
Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive. RRS feed

  • Question

  • User1297564232 posted

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

    Parser Error Message: Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive.

    It's Working On IIS But When I Host This To Web Server error Occured Like This

    Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive.

    Wednesday, January 8, 2014 2:50 AM

Answers

  • User-1454326058 posted

    Hi Pradip26,

    Do you check the .net framework’s version of application pool that the website used in your server?

    If it is .net framework 4.0 or later, please try to register the framework with IIS:

    C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319>aspnet_regiis -i

    There is a thread may benefit you:

    http://stackoverflow.com/questions/7530725/unrecognized-attribute-targetframework-note-that-attribute-names-are-case-sen

    Thanks

    Best Regards

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, January 9, 2014 1:20 AM
  • User71929859 posted

    It's Working On My IIS But When I Host Then Throws Error

    We understand that.

    Ask your hosting provider to change the .NET framework to 4.0. If there is configuration in the control panel of that hosting space, do it yourself.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, January 9, 2014 9:38 PM
  • User-1454326058 posted

    Hi Pradip26,

    For the application project:

    1. Right click the project in the VS
    2. Select Properties
    3. Select Application tab
    4. Change the Target framework (Dropdownlist)

    For the website project:

    1. Right click the website project in the VS
    2. Select start options
    3. Select Build tab
    4. Change the Target framework (Dropdownlist)

    For the IIS application pool:

    1. Right click the application pool
    2. Select Basic Settings…
    3. Change the .NET Framework version (Dropdownlist)

    Thanks

    Best Regards  

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, January 10, 2014 4:02 AM

All replies

  • User-1716253493 posted

    Seem like your application still configured as asp.net 2.0 application.

    Check application pool.

    Wednesday, January 8, 2014 3:17 AM
  • User-1378019758 posted

    Hi Pradip,

    Please make sure you change you asp.net version to asp.net 4. Go to application pool and then change it to version 4. It will solve your problem

    Thursday, January 9, 2014 12:02 AM
  • User1297564232 posted

    Hello Ben_HFL

    It's Working On IIS But When I hosted On Server They Throws error

    Thursday, January 9, 2014 12:05 AM
  • User-1454326058 posted

    Hi Pradip26,

    Do you check the .net framework’s version of application pool that the website used in your server?

    If it is .net framework 4.0 or later, please try to register the framework with IIS:

    C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319>aspnet_regiis -i

    There is a thread may benefit you:

    http://stackoverflow.com/questions/7530725/unrecognized-attribute-targetframework-note-that-attribute-names-are-case-sen

    Thanks

    Best Regards

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, January 9, 2014 1:20 AM
  • User1297564232 posted

    HI  Starain

    It's Working On My IIS But When I Host Then Throws Error

    Thursday, January 9, 2014 1:29 AM
  • User-1454326058 posted

    Hi Pradip26,

    What do you mean the Host? Please provide the details.

    Thanks

    Best Regards  

    Thursday, January 9, 2014 3:06 AM
  • User1297564232 posted

    host like www.example.com

    Thursday, January 9, 2014 3:09 AM
  • User71929859 posted

    It's Working On My IIS But When I Host Then Throws Error

    We understand that.

    Ask your hosting provider to change the .NET framework to 4.0. If there is configuration in the control panel of that hosting space, do it yourself.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, January 9, 2014 9:38 PM
  • User-1454326058 posted

    Hi Pradip26,

    Do you mean, you got the error when you just add the host name to the website in the IIS?

    Please try to clear the team files which path like C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\ (delete the corresponding folder)

    On the other hand, please try it with the new project.

    BTW: Could you share the project to us? About share the files in the SkyDrive, please refer to:

    http://windows.microsoft.com/en-us/skydrive/share-file-folder

    Thanks

    Best Regards  

    Thursday, January 9, 2014 9:38 PM
  • User1297564232 posted

    HI  Ruchira

    If I create Any sample Page in .net FrameWork 2.0 Then it's Working on Web Server.

    So .net Framework4.0 Not Installed On Web Server

    Thursday, January 9, 2014 10:53 PM
  • User71929859 posted

    If I create Any sample Page in .net FrameWork 2.0 Then it's Working on Web Server.

    Because of this

    So .net Framework4.0 Not Installed On Web Server

    You can't say that.

    Can you please confirm with your hosting provider? We understand that it's working in your machine and it's not working in the host and all. We are trying to tell you that you have to configure your application on the host to use .NET framework 4.0.

    Thursday, January 9, 2014 11:27 PM
  • User1297564232 posted

    Hi Ruchira

    Thanks For Ur Reply

    I can Do as u Say If Any Problem Regarding To This Then I Tell

     

    Thursday, January 9, 2014 11:31 PM
  • User-1378019758 posted

    Hi Ruchira

    Thanks For Ur Reply

    I can Do as u Say If Any Problem Regarding To This Then I Tell

    Hi Pradip,

    As I said previously, you need to change your .net version to .net 4. :)

    Friday, January 10, 2014 12:30 AM
  • User1297564232 posted

    what is Step To Change Framework

    Friday, January 10, 2014 12:48 AM
  • User-1454326058 posted

    Hi Pradip26,

    For the application project:

    1. Right click the project in the VS
    2. Select Properties
    3. Select Application tab
    4. Change the Target framework (Dropdownlist)

    For the website project:

    1. Right click the website project in the VS
    2. Select start options
    3. Select Build tab
    4. Change the Target framework (Dropdownlist)

    For the IIS application pool:

    1. Right click the application pool
    2. Select Basic Settings…
    3. Change the .NET Framework version (Dropdownlist)

    Thanks

    Best Regards  

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, January 10, 2014 4:02 AM