none
Bing Maps Infobox Pins stay on top RRS feed

Answers

  • Are you adding your pushpins to the DataLayer MapLayer like the code sample? That code sample uses two MapLayers, one for the InfoBox and the other for pushpins. The InfoBox layer is above the pin layer and should always appear above the pins.

    http://rbrundritt.wordpress.com

    Tuesday, January 28, 2014 8:44 AM
  • I fixed it my adding all pins to a completely new layer I made 
    Its weird but it works 

    • Marked as answer by blackasninja Friday, January 31, 2014 12:59 AM
    Friday, January 31, 2014 12:59 AM

All replies

  • Are you adding your pushpins to the DataLayer MapLayer like the code sample? That code sample uses two MapLayers, one for the InfoBox and the other for pushpins. The InfoBox layer is above the pin layer and should always appear above the pins.

    http://rbrundritt.wordpress.com

    Tuesday, January 28, 2014 8:44 AM
  • Ok I changed the one line I had that was making it wrong the first time so now they are a different layers. But now nothing shows up on on the map all. Till now my method has been to go through a list of locations and produce the values needed. The foreach loop for the list calls the method "AddPushPin" which seems to be running fine. Ive only changed the description around to number for distance (Changed in the other methods like the MetaData Class). Ive tried to hardcode a location in but even that doesnt show up
    Tuesday, January 28, 2014 8:34 PM
  • I fixed it my adding all pins to a completely new layer I made 
    Its weird but it works 

    • Marked as answer by blackasninja Friday, January 31, 2014 12:59 AM
    Friday, January 31, 2014 12:59 AM