locked
[UWP]Background Audio Player Not Working RRS feed

  • Question

  • Hi Everybody,

    Working on Windows phone UWP app for Background Audio player.

    When I deploy and debug the app using visual studio to my phone app works perfectly but when I upload it to store for private beta testing and download it from store to my phone, app works but the tracks is not playing.

    I run so many test to check this, background task is running good and all message between foreground and background works fine but audio is not played.

    need help on this issue.

    Thanks!


    Thursday, April 7, 2016 12:59 PM

Answers

  • SetUriSource must be used with web resources or package resources only.

    For playing files stored anywhere else, either use a media source or a stream.

    Friday, April 22, 2016 4:16 PM

All replies

  • Hi Xtreame Dark,

    Welcome to the Developing Universal Windows apps forum!  

    Please read the sticky posts, especially the Guide to posting: subject line tags and Known Issues for Windows 10 SDK and Tools

    >>” when I upload it to store for private beta testing and download it from store to my phone, app works but the tracks is not playing.”

    Based on your description, I could not reproduce your issue. You’d better post some code here. For example, how did you play the audio files? Where’re these audio files?


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Friday, April 8, 2016 9:21 AM
  • https://social.msdn.microsoft.com/Forums/windowsapps/en-US/add7b2bb-b8d1-41be-bc27-2b6e2cf15a86/uwpbackground-audio-task-not-long-time-work-in-the-lumia-950950xl10586107?forum=wpdevelop
    Friday, April 8, 2016 9:35 AM
  • Hi Xavier,

    I found the problem. I am playing audio file stored in mobile or in SD card. but use the code mention in sample Background Audio which work if you deploy the app from visual studio but does not work when download app from the store. now I am using BackgroundMediaPlayer.Current.SetFileSource() instead of BackgroundMediaPlayer.Current.SetUriSource() which work fine but is slow.

    I don't understand why BackgroundMediaPlayer.Current.SetUriSource() does not work for local audio which are stored in phone and SD card or did I miss something?

    Thanks,

    Pankaj Panwar

    Friday, April 22, 2016 3:20 PM
  • SetUriSource must be used with web resources or package resources only.

    For playing files stored anywhere else, either use a media source or a stream.

    Friday, April 22, 2016 4:16 PM