locked
how to do not use any security on wcf? RRS feed

  • Question

  • User519414094 posted

    in wcf on .net 4.5 i do not want to use any security and set this config in wcf server and client :

         <basicHttpBinding>
                    <binding name="BasicHttpBinding_IMyService"  >
                     <security mode="None">
                     <transport clientCredentialType="None" />
                     </security>
                  </binding>
          </basicHttpBinding>

    but in client i received this error:

        The HTTP request is unauthorized with client authentication scheme 'Anonymous'. The
        authentication header received from the server was 'Negotiate,NTLM'.

    i do not want any security how can i handle it?
    i read many and many article and title on internet but all answers are inefficient.

    Monday, August 5, 2013 5:56 AM

Answers

  • User-837620913 posted

    In IIS you need to re-enable anonymous authentication.

    1. Open IIS Manager and navigate to the level you want to manage. For information about opening IIS Manager, see Open IIS Manager (IIS 7). For information about navigating to locations in the UI, see Navigation in IIS Manager (IIS 7).

    2. In Features View, double-click Authentication.

    3. On the Authentication page, select Anonymous Authentication.

    4. In the Actions pane, click Enable to use Anonymous authentication with the default settings.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, August 5, 2013 5:58 AM