none
Windows Communication Foundation Error While Trying To Install dotnet 3.0 runtime RRS feed

  • General discussion

  • Hello -
      I am trying to install the dotnet 3.0 runtime framework on XP Pro.
    Currently installed on the computer:
    Framework 1.1
    1.1 Hotfix (KB928366)
    Framework 2.0
    2.0 Security Update (KB928365)
    Included below is the error log.
    What do I need to do to successfully install 3.0 runtime framework?
    Thank you.
    ed.de

    Here is the error log from a few install attempts:
    [04/10/09,11:11:39] Windows Communication Foundation: [2] Error: Installation failed for component Windows Communication Foundation. MSI returned error code 1603
    [04/10/09,11:11:42] WapUI: [2] DepCheck indicates Windows Communication Foundation is not installed.
    [04/10/09,11:11:42] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
    [04/10/09,11:18:40] Windows Communication Foundation: [2] Error: Installation failed for component Windows Communication Foundation. MSI returned error code 1603
    [04/10/09,11:18:42] WapUI: [2] DepCheck indicates Windows Communication Foundation is not installed.
    [04/10/09,11:18:42] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
    [04/10/09,12:11:16] Windows Communication Foundation: [2] Error: Installation failed for component Windows Communication Foundation. MSI returned error code 1603
    [04/10/09,12:11:25] WapUI: [2] DepCheck indicates Windows Communication Foundation is not installed.
    [04/10/09,12:11:25] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
    • Moved by nobugzModerator Friday, April 10, 2009 8:53 PM setup q
    • Changed type YiChun Chen Friday, April 17, 2009 3:31 AM Do not follow up
    Friday, April 10, 2009 7:29 PM

All replies

  • According to the .Net 3.0 requirements:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=10CC340B-F857-4A14-83F5-25634C3BF043&displaylang=en

    System Requirements

    • Supported Operating Systems: Longhorn (Windows Code Name) ; Windows Server 2003 Service Pack 1; Windows Vista; Windows XP Service Pack 2

    Not sure but maybe you need SP2...


    Is this all errors from log? What abour event log... Any info could be usefyll

    Regards
    Friday, April 10, 2009 7:51 PM
  • Hi Ed.de,

    Could you please try to help me to use collect tool to collect the log files of .NET Framework 3.0 from your "%temp%" folder?
    http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx

    Then compress them into a zip file and post a link back. You can upload your log files to SkyDrive and post the link back here.

    Steps:
    - Try to clean your "%temp%" folder
    - Install .NET Framework 3.0
    - Collect the logs from "%temp%" folder

    Thanks

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Monday, April 13, 2009 9:43 AM
  • Hi Ed.de,

    We are changing the issue type to “Comment” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by editing your initial post and changing the radio button at the top of the post editor window. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions.

    Thank you!
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Friday, April 17, 2009 3:30 AM