locked
.NET Framework 2.0 Not Present Error - But it is installed RRS feed

  • Question

  • User1983779442 posted

    I keep getting the error on one of our machines that .NET Framework 2.0 is not present but it is installed along with version 1.1. and 3.0. This error occurred with the AJAX Extensions 1.0 and I brute forced it in by command line and it works fine. We build applications in VS 2005/.NET Framework 2.0 on this machine all day long. Now I'm trying to install the Enterprise Library and it's giving the same error:

    Product: Enterprise Library 3.1 - May 2007 -- This installer requires the .NET Framework ver. 2.0 which is not present on the computer. Please install it and try again.

    Any help is appreciated....

    Wednesday, January 16, 2008 1:15 PM

Answers

  • User1520651454 posted

    it shouldn't affect 3.0. but if it does you can just re-install that framework the same way.  Wont affect any 3.0 apps.

    mcm

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, January 16, 2008 3:10 PM

All replies

  • User1520651454 posted

    just re-download and install the .net 2.0 framework.  all it will do is just re-install the framework, wont break anything.  Maybe your just missing a reg key or a file somewhere.

    hth,

    mcm

    Wednesday, January 16, 2008 1:31 PM
  • User-125547262 posted

    Just try a reinstall of the framework to make sure everything is done right. 

    Wednesday, January 16, 2008 1:31 PM
  • User1983779442 posted

    Okay, thanks for the advice...that was my concern that it would break the 3.0 install and such. I'll go ahead and reinstall.

    Wednesday, January 16, 2008 1:52 PM
  • User1520651454 posted

    it shouldn't affect 3.0. but if it does you can just re-install that framework the same way.  Wont affect any 3.0 apps.

    mcm

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, January 16, 2008 3:10 PM