locked
Very weird AJAX issue when on VPN RRS feed

  • Question

  • User-576969162 posted

    I'll try to be as brief as possible!

    I have a .net 3.5 web forms app deployed to ~150 users with windows authentication. Some users access this on the WAN, some via VPN, most without any problems. The site doesn't render properly on IE8+, so I have users up to and including IE11 using compatibility view and it works fine. It also works on Chrome with the IE Tab browser extension.

    PROBLEM: Lately two users have reported the site doesn't work properly but only when they are on a VPN connection (not sure what kind). When at work, no issues. One user, while on VPN, I have used Teamviewer to get onto their machine and reproduce the results:

    1. The site loads, it authenticates properly and the home screen loads as it should, but an initial control that expands using javascript does not expand; the site is unusable
    2. I logged into an alternate version of the site from their machine using my admin credentials and had the exact same result. I even remoted from their account to another server and accessed the site properly with their credentials, thus concluding account config is not a problem.
    3. I have had the same result on IE 9, 10, developer tools options, IE tab on Chrome--all behave the exact same way; the control doesn't work properly
    4. I tried various security options in IE including adding the web app's server to trusted sites list, but still no luck
    5. I see no errors or popup boxes of any kind.
    6. I am not a network guy, but it seems some trust issue of some sort when they are on VPN and accessing the server.

    Any ideas? I'm quite confident that a rebuild of their machine will fix it, since most users are fine, but I don't want to go that route as it is sloppy and this does affect two people.

    Tuesday, March 18, 2014 9:28 AM

Answers