none
Visual Studio 2015 does not launch anymore

    Question

  • Hey guys, please help me with my problem, I need to work but I cannot...

    So, at some point (which might be after installing Update 2, I am not 100% sure) Visual Studio stopped launching properly. After clicking the icon, the splash screen shows up but it never loads VS - it just hangs there.

    I tried Repair function from Programs and Features and it did help - I could launch VS again, but only once. The first instance opens up OK, but the second one again, won't load. When I close the first instance, I cannot open VS at all until I do 'Repair' again.

    I was desperate so I tried reinstalling it - but the effect was identical as in the case of Repair - first time I open it, it opens up fine, but it won't launch a new instance nor work after the first one is closed.

    It might be related to some extension or addon, I don't know - I am happy to disable anything just to make it consistently work.

    Cheers!

    ALSO - the ActivityLog.xml last entries below (there are no errors today and activity log datetime seems to suggest that its not updating in last ~10 hours....)

     
     <entry>
        <record>87</record>
        <time>2016/04/19 11:34:28.019</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Entering function VBDispatch::GetTypeLib</description>
      </entry>
      <entry>
        <record>88</record>
        <time>2016/04/19 11:34:28.019</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Leaving function VBDispatch::GetTypeLib</description>
        <guid>{80CC9F66-E7D8-4DDD-85B6-D9E6CD0E93E2}</guid>
      </entry>


    And - Event Viewer - I cannot find any meaningful activity, the only thing that is logged when I start VS is an info from one of VS extensions, AutomaticVersions

    Tuesday, April 19, 2016 7:38 PM

Answers

  • Hi Bartosz Jarmuz,

    >> It might be related to some extension or addon, I don't know - I am happy to disable anything just to make it consistently work.

    Please try run your Visual Studio in safe mode to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.

    If it can be opened in safe mode, this problem is caused by Visual Studio packages and extensions.

    Then please try run your Visual Studio as administrator to make sure whether this problem caused by the permissions for your Visual Studio.

    And please close all third part software when launch your Visual Studio, such as antivirus software.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Wednesday, April 20, 2016 9:09 AM
    Moderator