none
Word Add-In General Install Error after mandatory Windows 10 update RRS feed

  • Question

  • We have a VSTO Application that is installed on many machines. If the Add-In is already installed, there is no issue. If you try to uninstall or install, you get the following error message:

    The following Microsoft Office solution cannot be installed due to a general installer error: App_Name.vsto

    0x80070002

    This application has been working without hiccups for almost a year now. Our Sys Admin and I believe we've narrowed it down to a mandatory Windows 10 update (https://support.microsoft.com/en-us/kb/3173428) as our base Windows 10 image has it working fine and it works on Windows 7 no issue. However, the update is already pushed out and nothing is showing up in the logs.

    I know the VSTOInstaller.exe.Config file has been the cause for several of these installer issues, however I cannot find that file on any of our machines even though I KNOW I modified one machine and changed the name to VSTOInstaller.exe.Config.Old for the Business.fba error some have gotten. I assume an update somehow packaged the config file into the .exe.

    The Windows 7 machines also don't have the Config file as well...

    What we've tried:

    1. Searching for an older .Config file to place in the folder
    2. Rolling back to a previous version
    3. Recompiling
    4. Changing the publish destination folder and setting version back to version 1.0.0.0

    I'm at a loss. Any help is GREATLY appreciated.

    If anyone has the VSTOInstaller.exe.Config file, I'd love to try and place that in the folder to see if it works.


    ClickOnce VSTO Word Add-In.
    Friday, August 12, 2016 4:44 PM

All replies

  • >>If you try to uninstall or install, you get the following error message

    Do you mean the add-in couldn’t re-install or couldn’t  be installed on other computers which do not install the project before?

     

    >>Our Sys Admin and I believe we've narrowed it down to a mandatory Windows 10 update

    If you think this issue might cause from Windows 10 update, did you try to uninstall the update if it could?

    Is there any computer without windows updated and if the add-in could be installed or re-installed?

     

    >>know the VSTOInstaller.exe.Config file has been the cause for several of these installer issues

     

    Normally, VSTOInstaIIer.exe.Config doesn’t exist by default. If it is  VSTOInstaller.exe.Config or VSTOInstaller.exe.Config.Old that cause the issue, I would suggest you reinstall VSTO Runtime firstly.

    Besides, you can check the thread here to get more information about VSTOInstaIIer.exe.Config.

    Wednesday, August 31, 2016 11:02 AM
    Moderator