none
Universal Hello World driver (KMDF) cannot be installed in Win10 RRS feed

  • Question

  • Hi all,

    Is there anyone try to follow MSDN write a sample driver (as below link path) & install in your system?https://docs.microsoft.com/en-us/windows-hardware/drivers/gettingstarted/writing-a-very-small-kmdf--driver

    My question is I follow above sample code and build by VS2017 + WDK10, it can build successfully, but I cannot install from DM\Add legacy hardware\

    The folder you specified doesn't contain a compatible software driver for your device. if the folder contains a driver, make sure it is designed to work with windows for x64 based systems

    Anyone can share your experience for this issue?

    Wednesday, March 27, 2019 2:41 AM

Answers

  • Select build type (Debug or Release) and architecture (x64 or Win32 for x86) at the top of Visual Studio

     -Brian


    Azius Developer Training www.azius.com Windows device driver, internals, security, & forensics training and consulting. Blog at www.azius.com/blog

    • Marked as answer by Darkwindscan Thursday, March 28, 2019 6:17 AM
    Wednesday, March 27, 2019 7:20 PM
    Moderator

All replies

  • Build the driver for x64 (the default is frequently x86, which is labeled as Win32 in Visual Studio)

     -Brian


    Azius Developer Training www.azius.com Windows device driver, internals, security, & forensics training and consulting. Blog at www.azius.com/blog

    Wednesday, March 27, 2019 2:56 AM
    Moderator
  • Hi Brian,

    Thanks for your information, could you share how to change freqently to x64 from x86,

    I try to select configuration debug\x64 but still cannot install sample driver,

    or any setting I need to change from project\properties? 



    Wednesday, March 27, 2019 7:14 AM
  • Select build type (Debug or Release) and architecture (x64 or Win32 for x86) at the top of Visual Studio

     -Brian


    Azius Developer Training www.azius.com Windows device driver, internals, security, & forensics training and consulting. Blog at www.azius.com/blog

    • Marked as answer by Darkwindscan Thursday, March 28, 2019 6:17 AM
    Wednesday, March 27, 2019 7:20 PM
    Moderator
  • Hi Brian, it works, but I built driver with this setting before, maybe I need to clean build.

    Thanks again.

    Thursday, March 28, 2019 6:18 AM