none
No data is being pushed to configuration change table in log analytics RRS feed

  • Question

  • Change tracking is enabled on azure virtual machines . However no logs are flowing to configuration change table in log analytics. Can someone help me to fix this issue. I am not sure what else is missing. 

    Wednesday, December 4, 2019 11:25 AM

All replies

  • Are you sure you are searching for the data in the right log analytics workspace. though the dashboards for change tracking are under azure automation account. In general, azure automation and log analytics workspace get integrate when you enable the change tracking. You can check for the data in the Log Analytics workspace by running the search query :-  

    ConfigurationChange

    You will see entry in the search results. If you don't see any entry for 'ConfigurationChange'. then run the query :-

    search * | distinct Computer

    if you don't see the name of the computer from where you are expecting the data then

    try to reinstall the Microsoft Monitoring agent. and keep on 'OperationsManager' event logs.

    Thursday, December 5, 2019 6:58 AM
  • Thanks for the reply . I am aware of the query . I tried to check in log analytics configurationchange table and I dont see any data. 
    Thursday, December 5, 2019 7:23 AM
  • Not getting data for anything like Heartbeat ? if that's the case then it could be the issue with the Agent. 

    "Operations Manager".

    or it is only specific to "ConfigurationChange" ?

    Friday, December 6, 2019 10:12 AM
  • Hi PC_chipri,

    Is this still an issue ? If yes, as Keshav suggested, please double check whether you are querying the 'ConfigurationChange' table in the correct Log Analytics workspace or not.

    If you have already checked it and if you are querying in the correct Log Analytics workspace then I suggest you to check whether your agents' operating system holds good with the supported operating system versions as explained here.

    If that is also not an issue then can you share what output comment you are seeing when you query 'ConfigurationChange' table ? Is that '0 records matched for the selected time range' or 'Failed to resolve table or column or scalar expression named' or something else ?
    Monday, December 9, 2019 1:28 PM
    Moderator
  • Sharing for the benefit of broader audience.

    User has found out that there is a new preview feature in Azure called Scope Configuration under Workspace Data sources tab in which it creates a group of the servers for which change tracking is enabled by default and it has to be succeeded. User was facing this issue because the group went into initializing state instead of success. User have deleted the group and logs were flowing to the configuration change table.

    Friday, December 13, 2019 11:45 AM
    Moderator