locked
SSCM Windows 10 and Server Core 2016 RRS feed

  • Question

  • Seriously!!! I need help! I can't figure this out for the life of me!!

    I first had issues managing my service instances until I got help here:

    https://social.msdn.microsoft.com/Forums/sqlserver/en-US/3deb381c-6908-45e1-927a-08307d0d8a8a/using-sscm-remotely-to-sql-on-server-core?forum=sqltools#de0f25ae-86e0-414c-9d6f-ec1c3c104a60

    This was for SSMS 16.5 on Windows 10 LTSB...

    Then I'm not sure what happened (I honestly can't figure it out) I had to reboot my SQL server and everything worked EXPECT SSCM via the same technique provided in the initial thread above. (SSMS, Add Registered Servers, Right click added server and click the SSCM context menu. The other method to open MMC and add the computer mgmt snap-in and then point to the SQL server did not populate the SSCM options as mentioned in the top link. This seems to be missing with the latest SSMS installed on Windows 10) The problem was whenever I opened the SSCM via the registered servers context menu now simply reported an RPC error.

    https://social.msdn.microsoft.com/Forums/sqlserver/en-US/ad897d2d-c485-40cd-a3c1-d37bd85a4d67/sscm-reports-rpc-error-0x800706ba?forum=sqltools#c316bff1-8bb3-4024-8cc3-d90ad804cff1

    I have yet to get a response from anyone. So I decided to try my best to get it figured out... What I've tried:

    Renewing the vNIC (Turns out I had disabled IPv6 via registry and that was causing the sconfig network configuration issue.)

    Even after again disabling all firewalls, ensuring all services were reachable (I can connect to the server instance just fine via SSMS). Checked WMI via wbemtest, everything checks out, So I'm more than certain this is a layer 7 (application) issue with SQL Server 2016 and SSMS on Windows 10. Nothing resolved the issue.

    I went ahead and installed a complete fresh install of Windows 10 1607 (updated Jul 2017) and installed the latest version of SSMS 17.1. To my dismay I still can connect with Configuration Manager, to top off the ultimate annoyance this has been I find even more bad news...

    "Because SQL Server Configuration Manager is a snap-in for the Microsoft Management Console program and not a stand-alone program, SQL Server Configuration Manager does not appear as an application in newer versions of Windows."

    https://docs.microsoft.com/en-us/sql/relational-databases/sql-server-configuration-manager

    So following this I attempt to run it and it seems to fall under the exact same issue I had when I first attempted to use SSCM snap-in via my first post, only this time it simply reports an error stating WMI provider unavailable, mmm I wonder why that could be... maybe cause it's trying to connect to localhost when localhost is simply a MGMT computer designed to manager report services!!!! Thats what snap-ins are suppose to be!!! Why is it still not possible to remotely manage an SQL server with SSCM with the latest version of SSMS!?!?!?!? 

    Seriously this is getting extremely frustrating.

    How does one manage SQL Server Core 2016 from a Windows 10 machine?!?! (In particular the service instances, the only thing I can do is manage the actual service instance via the services.msc snap-in, then manage the TCP settings via the semi brokem SSCm on 16.5 SSMS install of Windows 10)

    Monday, May 29, 2017 5:32 PM

Answers

  • Just wanted to follow up. I had the issue come back, and double checked all my firewall rules and indeed I verified my WMI rules both in and out.

    After further trial and error I actually did discover the underlying issue. Which was due to a GPO I had created, when though I disabled the specific firewall GPO I had in place, I found the issue was still happening. digging further into another GPO that was being applied had the setting "Computer -> Policies -> Windows Settings -> Security Settings -> Windows Firewall with Advanced settings" I had JUST set the domain policy to be ON, while not configuring any other options. (Did not configure the default inbound and outbound results, or any of the other profiles). I adjusted attempted to adjust these settings to be all the defaults, yet even after doing that and a gpupdate it still wasn't working. I had to complete clear the policy settings by editing the GPO, navigating down to the Windows Firewall with advance settings object in the left hand navigation tree, right clicking it and selecting Clear policy from the context menu.

    I did a forced replication and then a gpupdate force on my mgmt computer, and finally the SCCM loaded all the instances in the snap-in.

    This makes way more sense than my previous answer. Cause It sure wasn't adding up, but this answer does.

    • Marked as answer by Zewwy Friday, July 14, 2017 3:51 PM
    Friday, July 14, 2017 3:51 PM

All replies

  • Hi Zewwy,

    Nice to see you again. What exactly is the issue at this moment? I’m not quite sure what you are facing right now, but I’d suggest you:
    1. Since your remote server is SQL Server 2016, you would need SQLServerManager13.msc to connect it remotely. I’d suggest you install SSMS 16.5.3 on your MGMT server as SSMS 17.x comes with SQLServerManager14.msc which is not going to work in your scenario.
    2. On your MGMT server, execute the command below in an elevated command prompt:
    mofcomp "C:\Program Files (x86)\Microsoft SQL Server\130\Shared\sqlmgmproviderxpsp2up.mof"
    3. On your remote server(Windows Server core 2016), enable Windows Management Instrumentation (WMI-In) in Windows Firewall with Advanced Security>>Inbound rules. 
    4. On your MGMT Server, execute the command below. Notice this command does require you to be a administrator on your remote server.
    C:\Windows\SysWOW64\mmc.exe /32 C:\Windows\SysWOW64\SQLServerManager13.msc /computer:REMOTESERVER
    If you have any other questions, please let me know.

    Regards,
    Lin

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, May 30, 2017 3:20 AM
  • Always da best Lin,

    I managed to figure it out after ripping my hair out forever! haha. It was due to the local workstation firewall.

    Basically I couldn't figure out why the initial way you showed me to connect all of a sudden stopped working. The only change I thought I did during that time was reboot the server and maybe some updates (There was a brief moment the enviro did have internet connection).

    I even created an "allow all" rule for both inbound and outbound for why local workstation. THIS IS NOT GOOD ENOUGH, oddly. So I ended up installing a Windows 7 machine (SP 2, I know not legit but the update MS provided is close enough) Then went ahead and insatlled SSMS (16.5). Even after installing this version the SSCM service node under compmgmt still doesn't exist. Seems to be a feature of older SSMS. I did disable the firewall on this Windows 7 machine (Since it was not part of the OU structure that had the firewall enforced settings) and sure enough the classic SSMS -> Registered Servers -> Right click instance -> SSCM context menu worked a treat!

    So I did the same to the Comp Object for my initial workstation (removed it from the OU) and did a gpupdate and reboot and verified the firewall was indeed completely off. Sure enough after that SSCM worked a treat.

    I just have to figure out now what exactly I need to open and allow on my GPO firewall rules, cause it seems to have buggered that one thing up. What's really odd about it all is that every other WMI/RPC featureof SSMS worked without a hitch, just not SSCM...how bazar, how bazar.

    Thanks for pitching in anyway. :)

    Tuesday, May 30, 2017 6:10 AM
  • Hi Zewwy,

    >>I even created an "allow all" rule for both inbound and outbound for why local workstation.

    On your initial workstation? If the rule doesn’t work, I’d first go and check everything under Windows Firewall with Advanced Security>>Connection Security rules. Anyways you have already narrow down the issue so it shouldn’t be too much trouble. 

    If you have any other questions, please let me know.

    Regards,
    Lin

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, May 30, 2017 7:02 AM
  • Thanks again Lin,

    After a bit more trial and error it was determined to be the WMI in rules on the workstation. I find that rather odd as it should be WMI out, and IN on the SQL server. learning new things everyday.

    I was still shocked that my "allow all" rules wasn't good enough for RPC/WMI packets though.

    • Marked as answer by Zewwy Tuesday, May 30, 2017 5:52 PM
    • Unmarked as answer by Zewwy Friday, July 14, 2017 3:51 PM
    Tuesday, May 30, 2017 5:45 PM
  • Just wanted to follow up. I had the issue come back, and double checked all my firewall rules and indeed I verified my WMI rules both in and out.

    After further trial and error I actually did discover the underlying issue. Which was due to a GPO I had created, when though I disabled the specific firewall GPO I had in place, I found the issue was still happening. digging further into another GPO that was being applied had the setting "Computer -> Policies -> Windows Settings -> Security Settings -> Windows Firewall with Advanced settings" I had JUST set the domain policy to be ON, while not configuring any other options. (Did not configure the default inbound and outbound results, or any of the other profiles). I adjusted attempted to adjust these settings to be all the defaults, yet even after doing that and a gpupdate it still wasn't working. I had to complete clear the policy settings by editing the GPO, navigating down to the Windows Firewall with advance settings object in the left hand navigation tree, right clicking it and selecting Clear policy from the context menu.

    I did a forced replication and then a gpupdate force on my mgmt computer, and finally the SCCM loaded all the instances in the snap-in.

    This makes way more sense than my previous answer. Cause It sure wasn't adding up, but this answer does.

    • Marked as answer by Zewwy Friday, July 14, 2017 3:51 PM
    Friday, July 14, 2017 3:51 PM