none
fixing .net frame work problem RRS feed

  • Question

  • Hi

    There are two utilities that checks the .net frame work on the system , I downloaded both, one of them checks and gives no error ( netfx_setupverifier.exe ) and the other one ( NetFxRepairTool.exe ) shows a list of file that has error and must be sent for analysis and recommends to use msiexe to solve.

    I read an article that is for older version of windows and recommend to reinstall the installed .net msi , but it is part of my windows installation and I dont have access to it/

    I am using VS2012 on windows 8 , I tried to install .net 4.5 again by downloading the executable file, but the installer says its part of windows and can't be reinstalled.

    Does anybody know how I can resolve the problem.

    Thanks in advance


    • Edited by albert19 Thursday, July 4, 2013 3:21 PM
    Thursday, July 4, 2013 6:41 AM

Answers

All replies

  • If this is the NetFxRepairTool you used:

    http://support.microsoft.com/kb/2698555

    Please note that it has not been updated to cover .NET Framework 4.0 or 4.5. I would take the results on these versions with a grain of salt if I were you.

    The verification tool we rely on is this one by Aaron Stebner:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    If this tool says your .NET 4.5 is good, I think you can rely on that.

    So, now the question is: What is going on with your VS 2012 that makes you think that your .NET 4.5 has issues?

    Thursday, July 4, 2013 5:24 PM
  • Thanks for your comment.

    No I used the same link that you approved above not the first one, and as I mentioned before,  netfx_setupverifier.exe shows no error in the system but NetFxRepairTool.exe shows error and a long list of files that has been sent for MS for analysis.

    My problem is this, I can not create a vspackage targeting .net 4 or before on VS2012 and the system gives few compile errors like :

    Error 17  The type or namespace name 'PackageRegistrationAttribute' could not be found (are you missing a using directive or an assembly reference?)

    when I want to add reference for Microsoft.Visualstudio.shell.10 for .net4 or Microsoft.Visualstudio.shell.9 for .net 3.5 , they are not in the list of references, I even installed VS2008 express to have them if they are not installed yet but still don't see .net 3.5 in control panel, I tried to install .net framework 3.5 but it wont install and does not give error too,I thought maybe my .net has problem in my system.

    I am totally confused , I just want to make a package to be installable on  VS2010 and VS2008 but still unsuccessful using VS2012 .

    Thursday, July 4, 2013 9:56 PM
  • "I tried to install .net framework 3.5 but it wont install and does not give error too,I thought maybe my .net has problem in my system."

    There is a specific procedure to install .NET 3.5 on Windows 8.

    Please read this:

    http://msdn.microsoft.com/en-us/library/hh506443.aspx

    Friday, July 5, 2013 1:13 PM
  • @PVDG42, Thanks again,

    I had read the article before and tried to enable the feature for .net 3.5 in control panel, but I don't still see .net 3.5 in the list of installed software in control panel after enabling this feature .

    Do you see  there after enabling the feature.

    Thanks


    • Edited by albert19 Friday, July 5, 2013 2:39 PM need more comment
    Friday, July 5, 2013 1:40 PM
  • You should find it in the Windows Features list.

    Control Panel->Programs and Features->Turn Windows features on and off...

    You can also use the .NET Framework Verification tool to see the .NET versions installed on your system:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    The first ~15 lines of the tool log lists all versions and installation status of each.

    Friday, July 5, 2013 2:26 PM
  • Thanks but my problem is not finding the location of .net 3.5 in control panel to enable, after enabling it I don't see .net 3.5 in the list of installed softwares that can be uninstalled, and also I still don't have reference to microsoft.visualstudio.shell.9 .
    Sunday, July 7, 2013 2:15 PM
  • "after enabling it I don't see .net 3.5 in the list of installed softwares that can be uninstalled"

    And, you won't. In Windows 8, .NET Framework 3.5 is a FEATURE (part of the OS) that is installed and activated optionally. If you have done that, and you see it in your features list, then you have it.

    As I said earlier, you can verify correct installation and configuration with this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Please run the tool with .NET 3.5 selected, then post the first 15 lines AND the LAST 15 lines of the tool log here.

    Sunday, July 7, 2013 2:35 PM
  • Thanks for your consideration:

    C:\Users\user1\AppData\Local\Temp\NetFxSetupEvents.txt

    C:\Windows\windowsupdate.log

    C:\Windows\logs\cbs\cbs.log

    C:\Users\user1\AppData\Local\Temp\FixDotNet.log

    C:\Users\user1\AppData\Local\Temp\dd_depcheck_VCS_EXP_90.txt

    C:\Users\user1\AppData\Local\Temp\dd_dotNetFx40_Full_x86_x64_decompression_log.txt

    C:\Users\user1\AppData\Local\Temp\dd_dotNetFx45_Full_setup_decompression_log.txt

    C:\Users\user1\AppData\Local\Temp\dd_dotnetfx45_full_x86_x64_decompression_log.txt

    C:\Users\user1\AppData\Local\Temp\dd_error_vcs_xcor_90.txt

    C:\Users\user1\AppData\Local\Temp\dd_ExpRemoteDbg_x64_MSI7243.txt

    C:\Users\user1\AppData\Local\Temp\dd_install_vcs_xcor_90.txt

    C:\Users\user1\AppData\Local\Temp\dd_MSDNExp_MSI7528.txt

    C:\Users\user1\AppData\Local\Temp\dd_NDP451-KB2823493-x86-x64-AllOS-ENU_decompression_log.txt

    C:\Users\user1\AppData\Local\Temp\dd_NetFxRepairTool (1)_decompression_log.txt

    C:\Users\user1\AppData\Local\Temp\dd_NetFxRepairTool (2)_decompression_log.txt

    C:\Users\user1\AppData\Local\Temp\dd_vs_professional_20130701180913_8_vc_compilercoreres.log

    C:\Users\user1\AppData\Local\Temp\dd_vs_professional_20130701180913_9_netfxdtp_48.log

    C:\Users\user1\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_20130704_021600000.html

    C:\Users\user1\AppData\Local\Temp\Microsoft .NET Framework 4.5 Setup_20130701_135653038.html

    C:\Users\user1\AppData\Local\Temp\Microsoft .NET Framework 4.5 Setup_20130701_180116201.html

    C:\Users\user1\AppData\Local\Temp\Microsoft .NET Framework 4.5 Setup_20130704_022333076.html

    C:\Users\user1\AppData\Local\Temp\Microsoft .NET Framework 4.5 Setup_20130704_022547460.html

    C:\Users\user1\AppData\Local\Temp\Microsoft .NET Framework 4.5.1 Preview Setup_20130701_134337914.html

    C:\Users\user1\AppData\Local\Temp\Microsoft Visual Studio 2008 SP1_20130704_201123224.html

    C:\Users\user1\AppData\Local\Temp\KB2600211_20130701_141605294.html

    C:\Users\user1\AppData\Local\Temp\KB2600211_20130701_142044662.html

    C:\Users\user1\AppData\Local\Temp\KB2600211_20130701_141605294.html

    C:\Users\user1\AppData\Local\Temp\KB2600211_20130701_142044662.html

    C:\Users\user1\AppData\Local\Temp\FixDotNet_HKCR_Installer.regdump

    C:\Users\user1\AppData\Local\Temp\FixDotNet_HKLM_Installer.regdump

    Sunday, July 7, 2013 3:29 PM
  • It appears that you have posted from the repair tool log, and not the verifier log.

    Please look under the download links in Aaron Stebner's article I linked for you. The file you need to download is netfx_setupverifier_new.zip

    When you open the archive, you need to extract the file netfx_setupverifier.exe. That is the executable you need to run.

    When you view the tool log, the first 15 lines will look something like this:

    [07/08/13,08:00:26] Beginning of new SetupVerifier activity logging session
    [07/08/13,08:00:26] Activity log file location: C:\Users\P_VAN_~1\AppData\Local\Temp\setupverifier_main_07-08-13_08.00.26.txt
    [07/08/13,08:00:26] Error log file location: C:\Users\P_VAN_~1\AppData\Local\Temp\setupverifier_errors_07-08-13_08.00.26.txt
    [07/08/13,08:00:26] Build created on September 10, 2012
    [07/08/13,08:00:26] Detected operating system: Windows 8 (x64)
    [07/08/13,08:00:26] For more information about repairing the .NET Framework, see http://support.microsoft.com/kb/2698555 and http://go.microsoft.com/fwlink/?LinkID=246062
    [07/08/13,08:00:26] Install state for .NET Framework 1.0: not installed.
    [07/08/13,08:00:26] Install state for .NET Framework 1.1: not installed.
    [07/08/13,08:00:26] Install state for .NET Framework 2.0: installed with service pack 2.
    [07/08/13,08:00:26] Install state for .NET Framework 3.0: installed with service pack 2.
    [07/08/13,08:00:26] Install state for .NET Framework 3.5: installed with service pack 1.
    [07/08/13,08:00:26] Install state for .NET Framework 4 Client: installed with no service packs.
    [07/08/13,08:00:26] Install state for .NET Framework 4 Full: installed with no service packs.
    [07/08/13,08:00:26] Install state for .NET Framework 4.5: installed with no service packs.
    [07/08/13,08:00:26] Windows directory: C:\WINDOWS
    [07/08/13,08:00:26] System directory: C:\WINDOWS\system32
    [07/08/13,08:00:26] Program Files directory: C:\Program Files (x86)

    And the last 15 lines:

    [07/08/13,08:00:52] Section [Registry GE - .NET Framework 3.5 SP1 (64-bit)] - start parsing entries
    [07/08/13,08:00:52] Section [Registry GE - .NET Framework 3.5 SP1 (64-bit)] - stop parsing entries
    [07/08/13,08:00:52] Section [Registry GE - .NET Framework 3.5 SP1 (Wow6432Node)] - start parsing entries
    [07/08/13,08:00:52] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5
     Value: SP
     Expected Data: 1
     Actual Data: 1
    [07/08/13,08:00:52] Section [Registry GE - .NET Framework 3.5 SP1 (Wow6432Node)] - stop parsing entries
    [07/08/13,08:00:52] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - start parsing entries
    [07/08/13,08:00:52] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - stop parsing entries
    [07/08/13,08:00:52] Processing custom action 'Custom Action - .NET Framework 2.0 test application'
    [07/08/13,08:00:52] ExecutablePath = 'Netfx20TestApplication.exe'
    [07/08/13,08:00:52] FriendlyName = '.NET Framework 2.0 test application'
    [07/08/13,08:00:52] TimeoutSeconds = '300'
    [07/08/13,08:00:52] WaitOnExit = 'true'
    [07/08/13,08:00:52] Silent = 'true'
    [07/08/13,08:00:52] Launching process 'Netfx20TestApplication.exe' now
    [07/08/13,08:00:52] Process successfully launched. Waiting 300 seconds for it to complete.
    [07/08/13,08:00:53] Process 'Netfx20TestApplication.exe' exited with return code 0
    [07/08/13,08:00:53] Not running action 'Files - .NET Framework netfxperf.dll' for product '.NET Framework 3.5 SP1' because the OS condition does not match
    [07/08/13,08:00:53] Verification succeeded for product .NET Framework 3.5 SP1

    Monday, July 8, 2013 1:04 PM