locked
SQL SERVER 2014 Error :40 RRS feed

  • Question

  • ""A network-related or instance-specification error occured while establishing a connection to SQL Server "" Windows Firewall is on ! what should i do , or change to connect , please help , please 


    • Edited by Soft Sujana Tuesday, August 26, 2014 2:20 AM
    Tuesday, August 26, 2014 2:16 AM

Answers

  • QUOTE from an article on the topic: "

    Firstly,

    Make sure your database engine is configured to accept remote connections

    • Start > All Programs > SQL Server 2005 > Configuration Tools > SQL Server Surface Area Configuration • Click on Surface Area Configuration for Services and Connections • Select the instance that is having a problem > Database Engine > Remote Connections • Enable local and remote connections • Restart instance  - See more at: http://www.sswug.org/articlesection/default.aspx?TargetID=44331#sthash.kzSfADZL.dpuf

    Secondly,

    You may need to create an exception on the firewall for the SQL Server instance and port you are using  • Start > Run > Firewall.cpl  • Click on exceptions tab   • Add the sqlservr.exe (typically located in C:\Program Files (x86)\Microsoft SQL Server\MSSQL.x\MSSQL\Binn, check your installs for the actual folder path), and port (default is 1433)  • Check your connection string as well - See more at: http://www.sswug.org/articlesection/default.aspx?TargetID=44331#sthash.kzSfADZL.dpuf

    Thirdly Check if your SQL server services is up and running properly

    Go to All Programs >> Microsoft SQL Server 2008 >> Configuration Tools >> SQL Server Configuration Manager >> SQL Server Services, and check if SQL Server service status is “Running”.

    In addition, ensure that your remote server is in the same network. Run “sqlcmd -L” in your command prompt to ascertain if your server is included in your network list. You can even find tutorial for the same here SQL SERVER – Find All Servers From Local Network – Using sqlcmd – Detect Installed SQL Server on Network.

    Next Enable TCP/IP in SQL Server Configuration

    Go to All Programs >> Microsoft SQL Server 2008 >> Configuration Tools >> SQL Server Configuration Manager >> Select TCP/IP. Right click and select enable

    Lastly Go to your firewall setting, under exception tab, select add port include TCP:1433 and tick the SQL check box."

    LINK: http://stackoverflow.com/questions/18060667/connect-to-server-a-network-related-or-instance-specific-error


    Kalman Toth Database & OLAP Architect SQL Server 2014 Design & Programming
    New Book / Kindle: Exam 70-461 Bootcamp: Querying Microsoft SQL Server 2012








    Tuesday, August 26, 2014 3:57 AM

All replies

  • QUOTE from an article on the topic: "

    Firstly,

    Make sure your database engine is configured to accept remote connections

    • Start > All Programs > SQL Server 2005 > Configuration Tools > SQL Server Surface Area Configuration • Click on Surface Area Configuration for Services and Connections • Select the instance that is having a problem > Database Engine > Remote Connections • Enable local and remote connections • Restart instance  - See more at: http://www.sswug.org/articlesection/default.aspx?TargetID=44331#sthash.kzSfADZL.dpuf

    Secondly,

    You may need to create an exception on the firewall for the SQL Server instance and port you are using  • Start > Run > Firewall.cpl  • Click on exceptions tab   • Add the sqlservr.exe (typically located in C:\Program Files (x86)\Microsoft SQL Server\MSSQL.x\MSSQL\Binn, check your installs for the actual folder path), and port (default is 1433)  • Check your connection string as well - See more at: http://www.sswug.org/articlesection/default.aspx?TargetID=44331#sthash.kzSfADZL.dpuf

    Thirdly Check if your SQL server services is up and running properly

    Go to All Programs >> Microsoft SQL Server 2008 >> Configuration Tools >> SQL Server Configuration Manager >> SQL Server Services, and check if SQL Server service status is “Running”.

    In addition, ensure that your remote server is in the same network. Run “sqlcmd -L” in your command prompt to ascertain if your server is included in your network list. You can even find tutorial for the same here SQL SERVER – Find All Servers From Local Network – Using sqlcmd – Detect Installed SQL Server on Network.

    Next Enable TCP/IP in SQL Server Configuration

    Go to All Programs >> Microsoft SQL Server 2008 >> Configuration Tools >> SQL Server Configuration Manager >> Select TCP/IP. Right click and select enable

    Lastly Go to your firewall setting, under exception tab, select add port include TCP:1433 and tick the SQL check box."

    LINK: http://stackoverflow.com/questions/18060667/connect-to-server-a-network-related-or-instance-specific-error


    Kalman Toth Database & OLAP Architect SQL Server 2014 Design & Programming
    New Book / Kindle: Exam 70-461 Bootcamp: Querying Microsoft SQL Server 2012








    Tuesday, August 26, 2014 3:57 AM
  • 1) If the Firewall is on you should check if port 1433 is opened, if not open it.

    2) For your SSRS open port 80 (i believe it's open by default) and 443 is you plan to use SSL on your SSRS environment.

    ** If this answer helped you please mark it as the answer :) **

    Wednesday, August 27, 2014 10:55 AM