none
Error inserting a list item to Sharepoint using WSS "Cannot complete this action" RRS feed

  • Question

  • I keep running into this error when attempting to insert an item into a sharepoint list:

    "The adapter failed to transmit message going to send port "SharepointTestResultUpload" with URL "wss://localhost:13561/semiworks/Lists/TestResult". It will be retransmitted after the retry interval specified for this Send Port. Details:"[Microsoft.SharePoint.Client.ServerException] Cannot complete this action.

    Please try again. Server Error Code: -2147467259Trace:    at Microsoft.SharePoint.Client.ClientRequest.ProcessResponseStream(Stream responseStream)
       at Microsoft.SharePoint.Client.ClientRequest.ProcessResponse()
       at Microsoft.SharePoint.Client.ClientRequest.ExecuteQueryToServer(ChunkStringBuilder sb)
       at Microsoft.SharePoint.Client.ClientRequest.ExecuteQuery()
       at Microsoft.SharePoint.Client.ClientRuntimeContext.ExecuteQuery()
       at Microsoft.SharePoint.Client.ClientContext.ExecuteQuery()
       at Microsoft.BizTalk.KwTpm.WssAdapter.ClientOmAccessor.RequestInfo.get_Lists()
       at Microsoft.BizTalk.KwTpm.WssAdapter.ClientOmAccessor.WebBucket.PopulateLists(RequestInfo reqInfo)
       at Microsoft.BizTalk.KwTpm.WssAdapter.ClientOmAccessor.WebBucket.SafePopulateLists(RequestInfo reqInfo)
       at Microsoft.BizTalk.KwTpm.WssAdapter.ClientOmAccessor.WebBucket..ctor(RequestInfo reqInfo)
       at Microsoft.BizTalk.KwTpm.WssAdapter.ClientOmAccessor.ListsAccessor.GetWebBucket()
       at Microsoft.BizTalk.KwTpm.WssAdapter.ClientOmAccessor.ListsAccessor..ctor(String siteUrl, String sharePointOnlineUsername, String sharePointOnlinePassword)
       at Microsoft.BizTalk.KwTpm.WssAdapter.ClientOmAccessor.ListsAccessor.TryOpenWebSite(String siteUrl, String sharePointOnlineUsername, String sharePointOnlinePassword, Exception& lastError)

    This error was triggered by the Windows SharePoint Services receive location or send port with URI wss://localhost:13561/semiworks/Lists/TestResult.

    Windows SharePoint Services adapter event ID: 12310"."

    I am running BizTalk 2013 and SharePoint 2010 on the same server and biztalk server configuration shows the SharePoint Adapter as successfully installed.

    Any help would be appreciated.

    Thursday, October 31, 2013 2:55 PM

Answers