locked
The Security Token Service is not available RRS feed

  • Question

  • I set up SharePoint 2010 Beta on a Windows 2008 R2 server and am going through the Central Administration - Review problems and solutions: All Reports - The Security Token Service is not available and the failing service is SPSecurityTokenService.

    Should not this service if available been installed during installation time? 

    It says "The Security Token Service is not issuing tokens.  The service could be malfunctioning or in a bad state.

    I don't want to go any further with setting up this until I can get an answer on how to fix this?

    Thanks
    Wednesday, December 9, 2009 7:58 PM

Answers

  • Bit late joining in here, but I battled with this for a while yesterday. I'm using Win 7 Ultimate with IIS 7.5. Having tried the above, I eventually found that the webservices in IIS were not started! (SharePoint Web Services) It's worth checking it out just in case you have the same (obvious!) error as me. I'm thinking that maybe the conflict of port 80 with 'default web site' may have caused this. Sharepoint also wants to operate on port 80, and it seems to cause a few problems within IIS

    Thanks for the suggestions above guys.

    Wednesday, May 19, 2010 11:04 AM
  • I checked in IIS and SecurityTokenServiceApplicationPool was stopped. After I started it, Security tokens works and also my Secure Store App finally works - I had an error Secure Store Shared Service is not responding. Thanks! I haven't even installed the KB Hotfix. Thanks!
    Monday, September 13, 2010 11:03 AM
  • Thanks for all the help on this one. Unfortunitely this didn't fix my issue but I have fixed this now with a very easy solution:

     

    Open the Services Window

    Start SQL Server Brower

    Obviously this only applies to the folks foolish enough to not have this set to automatic when installing SQL Server.

     

    Hope this helps.

    Saturday, July 2, 2011 12:07 AM

All replies

  • The Security Token Service is a Web service that issues security tokens, you can confirm whether or not the service is working by browsing to http://localhost:<port>/SecurityTokenServiceApplication/securitytoken.svc.  Prior to running Setup.exe and PSConfigUI.exe did you install http://code.msdn.microsoft.com/KB976462?
    Bill Baer, Technical Product Manager - US-SharePoint http://blogs.technet.com/wbaer
    Wednesday, December 9, 2009 8:12 PM
  • If you have installed the pre-requisites using the pre-requisites installer and the WCF Hotfix and then installed SharePoint 2010, just reboot. It should work. You should see that message disappear from Central Administration.

    Regards,
    Chakkaradeep || SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    Wednesday, December 9, 2009 9:05 PM
  • That worked thank you both, the Hotfix did the trick.
    Monday, December 14, 2009 6:48 PM
  • >>That worked thank you both, the Hotfix did the trick.

    Excellent :)

    Can you also mark the post(s) as answers? Thanks.
    Regards,
    Chakkaradeep || SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    Monday, December 14, 2009 8:15 PM
  • I'm also heaving "The Security Token Service is not available." problem in my beta SharePoint beta site. The hotfix mentioned above did not want to install onto my system - Win 2008 SP2.

    Regards,
    Dawid Ireno
    Friday, February 12, 2010 8:27 PM
  • i'm facing the same problem like alamandra with Sharepoint Foundation  2010.The hotfix doesn't work.

    The error is still showing up.

    Thanks in Advance

    Thursday, May 6, 2010 5:02 AM
  • The hotfix for Windows Server 2008 SP2 is available here:

    http://support.microsoft.com/kb/971831


    Rich Finn - http://blog.richfinn.net
    Saturday, May 8, 2010 2:12 AM
  • Rich will give that a try if it works.Tha
    Monday, May 10, 2010 1:02 AM
  • Bit late joining in here, but I battled with this for a while yesterday. I'm using Win 7 Ultimate with IIS 7.5. Having tried the above, I eventually found that the webservices in IIS were not started! (SharePoint Web Services) It's worth checking it out just in case you have the same (obvious!) error as me. I'm thinking that maybe the conflict of port 80 with 'default web site' may have caused this. Sharepoint also wants to operate on port 80, and it seems to cause a few problems within IIS

    Thanks for the suggestions above guys.

    Wednesday, May 19, 2010 11:04 AM
  • What I did

    1.  Installed windows 7 home premium

    2. Ran all updates

    3. Upgraded with anytime upgrade to windows 7 ultimate

    4.  Ran All Updates

    5. Went through the prereq list http://msdn.microsoft.com/en-us/library/ee554869%28office.14%29.aspx

    6. Installed Office

    7 Installed Sharepoint

    8. Installed Visual Studio 2010 professional;

     

    Now it says "SecurityTokenService" is not available. 

     

    I downloaded the patch above and it still doesn't work.  I am unable to retract solutions through the sharepoint admin site, I have to use stsadm.exe to do it due to this service not working.

     

    I went through my event viewer and the application log says something along these lines,

    "One of your applications is not configured for Windows Authentication"

     

    So I went into IIS Admin and check the authentication methods on all the sites, they are all set to windows authentication.  I also have All IIS features turned on except ASP Classic.

    The only thing I can think, is I downloaded the patch above after I installed sharepoint, maybe I should have done the patch first?

    Saturday, July 31, 2010 11:17 PM
  • Never mind, I figured it out.

    I missed a couple patches from the installation guide, or should I say installed them incorrectly.  The link to that guide is here in case it's not posted somewhere above, http://msdn.microsoft.com/en-us/library/ee554869%28office.14%29.aspx, 

    What I did to resolve this was the following.

    1. Uninstalled Sharepoint 2010

    2. Competely uninstalled IIS from Widows 7.

    3. Rebooted

    4. Went through the guide again, EXACTLY as it says.

     

    Pay close attention to Step 3 #5.  My mistake was I had SQL Server Native installed and assumed I could prepatch before installing sharepoint, this is wrong.

    The patches will apply to every version of native sql / express etc you have installed. 

    A Standalone Sharepoint installation uses its own SQL Express server, it will install anotehr one with it's own service called "Sql Service (SHAREPOINT)"  because of that, if you run the patches before you install sharepoint SQL Server Sharepoint will not have the patches. 

    You must install them AFTER installing sharepoint.

     

    Between that mistake, and the WCF hotfix posted above and The Filter Pack I forgot to install, I resolved my issue.

    Sunday, August 1, 2010 4:01 AM
  • I installed Search Server Express 2010 (RTM, not beta version) on Windows Server 2008 R2 and Health Analyzer gives me "The Security Token Service is not issuing tokens.  The service could be malfunctioning or in a bad state."

    Do the patches Bill mentioned apply to the released versions as well?

     

    TIA,

     

    Barkingdog

     

    Friday, August 20, 2010 7:39 AM
  • I checked in IIS and SecurityTokenServiceApplicationPool was stopped. After I started it, Security tokens works and also my Secure Store App finally works - I had an error Secure Store Shared Service is not responding. Thanks! I haven't even installed the KB Hotfix. Thanks!
    Monday, September 13, 2010 11:03 AM
  • I had the same issue with my server running Windows 2008 R2 member server to a domain.

    After installing SharePoint 2010 and attempting to run the Managed MetaDate Term Store Management tool i received the same error, the Security Token Service is not available.

    After much searching and head scratching I found that the SecurityTokenServiceApplicationPool was running under the .Net Framework V4.0.xxxxx and the other services under V2.0.xxxxx, changing this app pool to the version 2.0.xxxxx same as the rest made it work for me.

    no more errors

    thanks for all the suggestions and support guys

    wolf

    Monday, December 13, 2010 5:18 AM
  • Error An unexpected error has occurred. Troubleshoot issues with Microsoft SharePoint Foundation. Correlation ID: fe4374a1-450f-4633-b9f6-a1fa8818e691 Date and Time: 4/1/2011 5:02:09 PM

     

    This error is occur....

    SharePoint 2010 search is not working..

    Friday, April 1, 2011 12:04 PM
  • Thanks for all the help on this one. Unfortunitely this didn't fix my issue but I have fixed this now with a very easy solution:

     

    Open the Services Window

    Start SQL Server Brower

    Obviously this only applies to the folks foolish enough to not have this set to automatic when installing SQL Server.

     

    Hope this helps.

    Saturday, July 2, 2011 12:07 AM
  • I struggled with this same error.  None of the above mentioned issues fixed my problem.  What did solve my problem was changing an App Pool settings on the SecurityTokenServiceApplicationPool.  The Enable 32-Bit Application setting was set to True.  Changing the setting to False and reseeting the app pool suppressed my error.

    Thanks everyone

    • Proposed as answer by .Net_Doug Tuesday, July 17, 2012 9:38 PM
    Tuesday, July 17, 2012 9:38 PM
  • Hi,

    Non of those worked with me, except the following :)

    • Missing WCF Hotfix: If the server is running Windows Server 2008 SP2, please ensure that the hotfix mentioned at http://support.microsoft.com/kb/971831 is installed. If the server is running Windows Server 2008 R2, the hotfix mentioned at http://support.microsoft.com/kb/976462 must be installed.
    • Incorrect Authentication Settings: Please ensure that the authentication settings for the SecureTokenServiceApplication are correctly configured by completing the following steps:
      a) Open IIS Manager
      b) Expand “Sites”
      c) Expand “SharePoint Web Services”
      d) Select “SecurityTokenServiceApplication”
      e) From the “Features” pane, double click on “Authentication” under “IIS”
      f) Right click “Forms Authentication” and select “Disable”
      g) The authentication settings page should only have Windows and Anonymous access enable for the security token service to issue tokens properly (and for claims authentication to work properly)
    • Incorrect data in the configuration file: Please review the web.config file of the secure token service application and compare it to a web.config file from a "working" secure token service application.
    • SecureTokenServiceApplication not provisioned: Use the following power shell commands to provision the secure token service application
      $sts = Get-SPServiceApplication | ?{$_ -match "Security"}
      $sts.Status
      $sts.Provision()​
    Sunday, December 9, 2012 10:23 AM
  • I had this problem recently and tried all the options suggested in this post without success.

    Luckily it worked finally and thought to post an update for those who might face it in the future.

    The issue wasn't with the STS in particular, but with localhost in general.

    This said, you have also the reporting and toplogy web services located under the same IIS web site directory "SharePoint Web Services"; try browsing any WCF service and not just the STS service and see if you can see it working in the browser.

    If you still cannot, verify that you even can browse any localhost page using your browser, even with a static html page such as http://localhost/test.html.

    I had the problem of localhost not working at all in my machine and it was because of netsh!
    Double check that netsh is not listening to the machine IP.
    To check whether the IP is being listened to or not, type:
    netsh http show iplisten
    If the IP is listed, remove it using:
    netsh http delete iplisten ipaddress=your ip
    Hope it works for you


    Ahmed Abuabdou, Senior SharePoint Architect, ELM

    Wednesday, October 7, 2015 4:34 PM
  • I have this problem. I saw it stopped I started it but a few minutes later it stopped again do you know why it stopped automatically?
    Wednesday, June 7, 2017 5:24 AM