none
Kinect SDK Issue - No depth and RGB stream at the same time. RRS feed

  • Question

  • Hi, I have an issue with the kinect SDK on my laptop where I can't display both the RGB and depth stream at the same time. For example, in the skeleton viewer example, only the depth image and skeleton information are displayed, but not the RGB image.

    It does work fine on my desktop at home however.

    Is this a known issue? Nothing else is connected via USB on the laptop, but the cpu is a dual core AMD, while I have an Intel at home.

    Thank you,

    Max

    Tuesday, October 11, 2011 7:31 PM

All replies

  • I haven't seen this issue before. Can you display RGB image at all in this device, if you only initialize RGB image stream and not depth stream? Do you see any exceptions or error codes?

    Eddy


    I'm here to help
    Wednesday, October 12, 2011 7:37 AM
  • Are you using a proper USB 2 port?  What are the laptop's specifications?
    Wednesday, October 12, 2011 2:12 PM
  • Yes, it displays RGB images quite well, using only the useColor option. The problem arises using both the useColor and useDepth streams.

    If it helps, I tried the OpenNI drivers this morning, and it displays both, but heavy tearing and flickering on the RGB, before crashing.

    The Laptop is a brand new Toshiba with an AMD E-350. It's a bit low for the requirements, and maybe it has to do with the USB bandwidth on the AMD chipset, or the multicore performance.

     

    Wednesday, October 12, 2011 3:59 PM
  • I also just read that the E-350 only has single-channel memory controller. This could affect the processing.
    Wednesday, October 12, 2011 4:00 PM
  • Here's another observation. Using OpenNI and Linux seems to solve the problem, both images display well.

    Now, I would like to use the SDK on Windows. Is this issue related to the SDK, or my computer and OS?

    Thanks for your help, hopefully this will help someone else also.

    Sunday, November 6, 2011 9:54 PM
  • Have you uninstalled the OpenNI drivers prior to installing the Kinect 4 Windows Beta 2 SDK? If not, try to uninstall the OpenNI drivers, uninstall Beta 2 SDK if installed (or the Beta 1 SDK if it's installed), reboot, and install the Beta 2 SDK again. Give the SkeletalViewer SDK sample a try.

    If this still doesn't work, can you make sure that in the Device Manager you're seeing the Kinect installed? Also, can you provide us information about what USB controller you have on your machine?

     

    Thanks,

     

    Robert.

    Friday, November 11, 2011 4:34 AM
  • Yes, the OpenNI drivers have been uninstalled and I am running the Beta 2 SDK. It does seem to improve a bit, (the RGB images refresh every 10-20 seconds instead of not at all). The skeleton and depth feature work well, although at a low frame rate (5fps at most). 

    In the device manager I can see the Kinect Camera, device and audio array under Microsoft Kinect.

    I'm not sure what the hardware is for the USB controller. This laptop is a toshiba c650D with an AMD e350 chipset.

    The Kinect is connect to the Standard Enhanced USB to PCI host controller. There is also a Standard OpenHCD controller in the list.

    Friday, November 11, 2011 3:46 PM
  • From what i looked up, the processor is at 2.1GHz - is that right?  FYI, the minimum machine spec is 2.66GHz.  However we'd love to have the USB controller info as well so we can look into that.  Can you share the hardware that you see in Device Manager - you could upload a screenshot of the USB section.
    Friday, November 11, 2011 4:49 PM
  • Yes, I know the CPU is under the specs. However my single core Intel Atom N450 netbook at 1.6 GHz is capable of displaying the 2 streams at a low FPS.

    Here is a screenshot of the device Manager with the USB section as well as CPU:

    Monday, November 14, 2011 2:56 PM
  • Do you have any other USB devices plugged into the machine? If so, try unplugging them and only keep the Kinect plugged in when you try the sample.
    Monday, November 14, 2011 6:37 PM
  • I have tried that too, but it doesn't solve the issue. Maybe this is a specific chipset issue? Is that possible? Are AMD chipsets less compatible with Kinect?
    Tuesday, November 15, 2011 3:22 PM
  • As Bob mentioned, our minimum requirements are a 2.66GHz machine. It looks like your machine is a bit under the minimum requirements.
    • Proposed as answer by ykbharat Sunday, May 6, 2012 11:58 AM
    Tuesday, November 15, 2011 4:28 PM