locked
Can't uninstall Visual Studio 2010 RRS feed

  • Question

  • I can't uninstall Visual Studio 2010 from my pc with Vista Ult 32bit. Trying from control panel just gives me error: "A problem has been encountered while loading the setup componenets." If I try the Visual Studio Uninstall untility it gets halfway done and hangs indefinately. I let it run for 6 hours and it just stayed at halfway done. So how do I get rid of this?
    Friday, March 25, 2011 6:24 PM

Answers

All replies

    • Proposed as answer by Andrew.Wu Monday, March 28, 2011 6:23 AM
    • Marked as answer by Andrew.Wu Sunday, April 3, 2011 1:50 PM
    Saturday, March 26, 2011 7:31 AM
  • Sorry, but you answer is crap. Besides posting some links which one can easily google up you are also proposing (see the first link) the user to install PerfectUninstaller which is a malware app.

    Regards,

    David

    Tuesday, April 17, 2012 2:08 PM
  • I have the same issue with not being able to uninstall.  I have tried every method of uninstalling and at this point, I may have to reformat to get rid of this product.  I am not very happy with Microsoft at the moment.  Uninstall should not be an issue of this magnitude and nobody that has posted about this issue has had any answers.
    Monday, June 4, 2012 3:24 PM
  • David:

    I just had the same problem, but noticed it when I couldn't open Visual Studio 2010.  I had a missing MSI installer.  I ran the .Net SP1 install manually that allowed me to open VS. 

    1. Click Start -> Search
    2. In Files and Folders text box, enter VS*.*
    3. Double click VS_setup and run it.
    4. Double click VSStor_X86 and run it.

    This should help you open VS. This won't fix the uninstall issue. It will however, help you determine the exact errors in VS.  For example, my editor won't open now either, but there is a message that shows me what I am missing so I can proceed on patching the system one patch at a time. 

    Whatever the crash changed - damaged the MSI file on the computer enough so that the CD version -Visual Studio Installer does not recognize it.  They have two Windows Redistributable 3.1 and 4.5 patches out that you can try.  

    This information helps you run installer commands:

    http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/msiexec.mspx?mfr=true

    Try reviewing KB Article: http://support.microsoft.com/kb/969052

    This article denotes:

    These problems may occur when the Windows Installer database file (.msi) or the Windows Installer patch file (.msp) is missing from the Windows Installer cache. The Windows Installer cache is located in the following folder:%windir%\installerWhen a product is installed by using Windows Installer, a stripped version of the original .msi file is stored in the Windows Installer cache. Every update to the product such as a hotfix, a cumulative update, or a service pack setup, also stores the relevant .msp or .msi file in the Windows Installer cache.

    Any future update to the product such as a hotfix, a cumulative update, or a service pack setup, relies on the information in the files that are stored in the Windows Installer cache. Without this information, the new update cannot perform the required transformations


    Hope this helps.






    • Edited by Susan_F Friday, January 4, 2013 2:37 PM
    Friday, January 4, 2013 6:05 AM