none
Workflow Service Status : workflow not connected RRS feed

  • Question

  • Regarding Workflow Service Status : workflow is not connected

    SharePoint 2013 workflow requires a compatible workflow service configured with SharePoint such as Workflow Manager. The workflow service is either not installed or not configured

    • From the event viewer the error showed that it had some certificate error. I installed the certificate. After installing the certificate it said that i need to run the Register-SPWorkflowService command.

    I am unable to run this cmdlet. i tried this command shown below  and received the error. Please look into the same.

    Register-SPWorkflowService –SPSite "http://myserver/mysitecollection" –WorkflowHostUri "http://workflow.example.com:12291" –AllowOAuthHttp

    Error : Register-SPWorkflowService : Failed to query the OAuth S2S metadata endpoint at URI '_layouts/15/metadata/json/1'. Error details: 'The metadata endpoint responded with an error. HTTP status code: Forbidden.'

    Please let me know, if you have resolved the same or any idea how to resolve it??

    Friday, February 1, 2013 12:32 PM

All replies

  • Just to get more data - what credentials are you using when you run the cmdlet?  Are you running elevated?

    Thursday, February 28, 2013 1:49 AM
  • Neeraj, were you able to correct your configuration?
    Wednesday, March 20, 2013 6:33 PM
  • I'm battling with the same issue on a new SP2013 farm.  Any ideas anyone?
    Sunday, April 21, 2013 4:43 PM
  • In our case, I found that the AllowMetadataOverHttp and AllowOAuthOverHttp properties were set to False, as could be seen using Get-SPSecurityTokenServiceConfig.  In my case I had been omitting the –AllowOAuthHttp switch, as we are using https for the WorkflowHostURI.  BUT, are not using https for the SharePoint site, so I'm not sure if this switch also configures your SharePoint site.

    In our case i ran the Register-SPWorkflowService once with the switch and it still failed.  I was then going to change the properties of the SPSecurityTokenService using:

    $config = (Get-SPSecurityTokenServiceConfig) 
    $config.AllowOAuthOverHttp = $true 
    $config.AllowMetaDataOverHttp = $true 
    $config.Update() 

    ... only to find that the properties had already changed to true after the first run of Register-SPWorkflowService.  I then ran Register-SPWorkflowService again and it succeeded.  

    Not sure how right/wrong the above is... but it worked for me  ;-)

    • Proposed as answer by pmcleod Thursday, June 6, 2013 1:20 AM
    Tuesday, April 30, 2013 1:52 PM
  • $config = (Get-SPSecurityTokenServiceConfig) 
    $config.AllowOAuthOverHttp = $true 
    $config.AllowMetaDataOverHttp = $true 
    $config.Update() 

    Worked like a charm. Thanks!

    -Eugene

    Monday, May 13, 2013 9:58 PM
  • I ran into this same type of error, and the solution below didn't help me, in my case. What was happening was that I was running the PowerShell under my install account (I use sp_install); when I logged into the server as my Farm account (sp_farm), I was able to run this command successfully.

    I watched the archived Workflow webinar here at Rackspaceand it was very helpful (except for this little error :-) ). 

    • Proposed as answer by pmcleod Thursday, June 6, 2013 1:20 AM
    Friday, May 24, 2013 12:32 PM
  • Restarting IIS a couple of times on all SP15 farm servers, after installing the Workflow Manager Clients on all other servers besides the one hosting the Workflow Manger Farm (where the client installs itself with the Workflow Manger install), worked for me. The initial failure was similar to what is noted in this forum. 

    Radu P.

    Monday, July 22, 2013 8:53 PM
  • Worked like a champ for me with Share Point 2013 and WFM 1.0 (2010).  Two key factors in successful registration are sufficient user/admin privileges (Domain Admin worked in my case), and the -AllowOAuthOverHttp setting.  Even if you are using WFM at https, the -AllowOAuthOverHttp "True" flag was apparently required.  One other note is that for WFM listening at https, you cannot change the site name in IIS, and will need to ensure the SSL cert for the WFM server is in the Root Authority (fully qualified *.*.com, org, whatever), otherwise you will get the root certificate authority error noted in other threads regarding WFM registration.
    Tuesday, October 1, 2013 4:04 PM
  • Wow - I've been struggling with this error all day.  I ran your script above and then ran the register command and NO errors this time.  Thank you for posting.

    Wednesday, February 7, 2018 12:36 AM
  • Pleasure, glad it helped!
    Wednesday, February 7, 2018 5:43 AM